compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Jeu 05 Nov 2015, 01:58

.

Bonjour

Dernièrement j'ai posé un question relative à un "Compteur de visite PHP" ( < iCi > )
Notamment sur le décodage des "variables" avec caractères Accentués ...

à la reprise d'anciens "Phi" quel n'est pas la surprise de voir que la Nelle Version ne sait pas lire les données "accentuées" entrées dans un "tab"
Exemple:
Code:
//tableau pour la liste des titres des mp3
_root.tab1={
"Conquest of Paradise",
"Chi Mai",
"Continuum",
"El Condor",
"flûte de Pan",  <-------
"Heaven",
"Hymne",
"Mort du Loup",
"Petite Fille",
"Prelude",
"Singe Blue"};

En 5ème ligne --> "flûte de Pan"

Ancienne Version:
 

Dernière Version:
 

Sélectionnez la partition "flûte de Pan" dans l'ancienne et dans la Nelle Version

Voyez par vous même ... l'affichage après sélection Shocked

=========

Comme je suis un fervent utilisateur de la Fonction " Importswf("xxxxxxx",_root.zzzz); " pour éviter les temps morts de chargement (notamment sur Forum)

Impossible de la faire fonctionner ...  Evil or Very Mad  idem pour " ImportSwf_AtPos("ssssss",50,50); "

Heuuu .... quelles sont les solutions ..... Suspect

=========

Un autre problème exposé < iCi >

Et là ..... ça m'inquiète énormément car le programme est très complexe


.
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Jeu 05 Nov 2015, 20:53

est-ce que ca ne vient pas de ça, par hasard ?
admin a écrit:


Ok, c'est corrigé. E-anim convertit la variable en String (prêt pour la prochaine version)

Pour la conversion HTML->ascii, voici une fonction :
(Cette fonction sera inclue dans la prochaine version)
Revenir en haut Aller en bas
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Jeu 05 Nov 2015, 21:12

.

Hello "chris" Wink

Non je ne pense pas .... les variables passées en ouverture d'un swf ( xxxxx.swf?varget= ééééé) ont toujours eu le problème avec les caractères accentués ....

Là le problème est dans l'interprétation d'une variable à l'intérieur d'un "phi"

Exp: crée un texte variable  --> essai_text

envoie lui une valeur --> _root.essai_text = "c'est l'été";   tu vas voir le résultat Rolling Eyes


.
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 10:07

pas trop le temps de tester, si tu mets  
& eacute (sans espace)
pour é ?
Revenir en haut Aller en bas
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 10:41

chris_c a écrit:
si tu mets  
& eacute (sans espace)
pour é ?

Les résultats: Suspect





.
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 11:10

Bonjour

bizarre,j'ai essayer avec le gadget "saint du jour"

j'ai mis Gérard pour aujourd'hui pour avoir un accent et çà marche


Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 11:48

.

Avec la version 11 -01-02

Décidément c'est à rien n'y comprendre Evil or Very Mad



.
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 12:56

moi,c'est avec la version 11.01.004
Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 14:33

.


Gérard peux tu tester la Fonction   " Importswf " avec la version 11.01.004 Very Happy

Par avance merci
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 15:48

çà fonctionne aussi

j'ai importé l'animation que j'ai mis plus haut

Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 15:55

Merci Gérard pour ton test  Wink

il y a donc problème avec cette version --> 11.01.002  chargée le 19/09/2015  Suspect

Je vais charger la 11.01.004
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 18:27

j'ai regardé ton zip

tu importes le swf dans une pièce nommée cible

ImportSwf("bandeau",_root.cible);

supprimes là et tu crées un groupe nommé cible et çà fonctionnera

ou tu mets ImportSwf("bandeau",_root); et çà sera importé dans écran de base en 0x0

Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 19:06

.

Merci Gérard pour ton intervention  Wink

Effectivement en créant un groupe (pour moi "cible") pour réceptionné l'import ça fonctionne  Very Happy

il faut bien par contre positionné le groupe "cible" à la position adéquate

======

Au paravent ... je mettais un rectangle (nommé "cible") à la position voulu pour l'import ...

Maintenant il faut que je fasse Gaffe, si je reprends un ancien "phi" de penser à modifier la procédure d'import

Encore grand à toi .... je ne voyais pas comment m'en sortir  scratch


Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 20:08

comme le swf est importé en 0x0 du groupe cible,tu mets un rectangle en 0x0 dans ce groupe et il servira de repère,
suffit de déplacer après le groupe cible à la position voulue en se servant du rectangle
Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Ven 06 Nov 2015, 20:24

.

Exact Gérard ... c'est une solution

lmc38510 a écrit:

Au paravent ... je mettais un rectangle (nommé "cible") à la position voulu pour l'import ...

La différence entre la procédure actuelle et l'ancienne:

Avant je ne créais pas de groupe "cible" .... je positionnais un rectangle (nommé "cible") en X...Y

Soit il me servait de cadre .... soit je passais sa "transparence" à "zéro" ....Heuuu... question d'habitude .... Wink


.
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
Contenu sponsorisé




Message Sujet: Re: [Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim   Aujourd'hui à 04:04

Revenir en haut Aller en bas
 
[Résolu] Incompatibilité Ancien PHI avec nouveau E-Anim
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» [/résolu] problème avec java à l'instalation :-/
» [résolu] une vidéo ajustable en taille avec bouton survol?
» [Résolu] Nouveau E-anim sous windows XP
» installer carte avec nouveau garmin express
» [Résolu] Problème avec psg tv

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: