Tout ce qui concerne le logiciel E-anim
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Est-ce normal?

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
akaspy
Accro
Accro
avatar

Nombre de messages : 127
Date d'inscription : 06/03/2017

Message Sujet: Est-ce normal?   Dim 28 Mai 2017, 17:55

Bonjour,

J'ai un groupe, qu'on appellera abc. Au temps 0, un stop, et à partir du temps 1 il y a un texte qui défile.
Ailleurs dans l'animation, j'ai une zone transparente avec une action immédiate qui lance le groupe abc au temps 1.

Quand l'animation arrive au temps où se situe la zone transparente, le texte apparaît et défile.

Jusque là, tout va bien.

Je copie le groupe abc, et je le colle directement (donc au même endroit. Je ne fais absolument rien d'autre entre le copier et le coller). J'obtiens un groupe abc0.

Dans la zone transparente, je ne change rien sauf que je mets un 0 à abc dans mon script. Donc le script est strictement identique sauf qu'au lieu de abc, j'ai abc0.

Et là, le texte ne défile pas ! En fait ça fait comme si j'avais changé le goto_and_play de mon script en goto_and_stop, pour être plus précis.

Est-ce que c'est logique..? Je m'arrache les cheveux depuis 2 heures...
Revenir en haut Aller en bas
gerard35
Modérateur global
Modérateur global
avatar

Nombre de messages : 6494
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: Est-ce normal?   Dim 28 Mai 2017, 20:32

Bonjour

si c'est fait comme tu dis, çà devrait marcher

tu peux refaire un exemple simple des même conditions et me passer un zip du dossier ?

parce que chez moi,j'ai refait comme tu dis et çà marche mais j'ai juste fait avec un petit rond comme témoin
Revenir en haut Aller en bas
http://geranim.free.fr/
akaspy
Accro
Accro
avatar

Nombre de messages : 127
Date d'inscription : 06/03/2017

Message Sujet: Re: Est-ce normal?   Dim 28 Mai 2017, 21:20

http://www.cjoint.com/c/GECtpZ3W7rw

j'avais fait 4 textes qui défilaient les uns après les autres (text_gen_1 à text_gen_4) avec une action immédiate à la fin de chaque groupe pour passer au texte d'après.
puis j'ai voulu ajouter un texte avant les 4 premiers (un titre), il s'appelle text_gen_0.
l'action qui démarre le tout est dans le groupe start.
Revenir en haut Aller en bas
akaspy
Accro
Accro
avatar

Nombre de messages : 127
Date d'inscription : 06/03/2017

Message Sujet: Re: Est-ce normal?   Dim 28 Mai 2017, 21:39

Quand j'essaie de changer l'action du groupe start pour faire démarrer text_gen_0 en premier, ça ne fonctionne pas. Si c'est text_gen_1 en premier, ça fonctionne.
Revenir en haut Aller en bas
akaspy
Accro
Accro
avatar

Nombre de messages : 127
Date d'inscription : 06/03/2017

Message Sujet: Re: Est-ce normal?   Dim 28 Mai 2017, 22:02

Les textes sont transparents aux premiers temps des groupes, mais si tu changes le script de l'action, en mettant par exemple goto_and_play(50, etc.... tu verras que c'est figé. Donc ça emmène bien à l'endroit voulu, mais ça stoppe au lieu de jouer l'anim.
Revenir en haut Aller en bas
gerard35
Modérateur global
Modérateur global
avatar

Nombre de messages : 6494
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: Est-ce normal?   Dim 28 Mai 2017, 22:55

il ne faut pas mettre d'action immédiate au temps 0 du groupe start

donc tu sélectionnes la zone action_start et tu cliques sur la petite flèche noire à gauche de la barre de temps
çà va la repousser au temps 1, ne pas oublier d'enlever le stop au temps 0
et après çà marche
Revenir en haut Aller en bas
http://geranim.free.fr/
akaspy
Accro
Accro
avatar

Nombre de messages : 127
Date d'inscription : 06/03/2017

Message Sujet: Re: Est-ce normal?   Dim 28 Mai 2017, 23:47

Ok merci.

J'ai continué de tenter de corriger ça de mon côté aussi. Et j'ai réussi aussi. Comment? J'en sais rien, honnêtement... Et en plus, action_start est au temps 0. Par contre il est invisible (dans l'absolu, on s'en moque) mais il est impossible à remettre visible. C'est pas conventionnel... Je comprends plus rien...

Il ne faut jamais mettre d'action immédiate au temps 0 d'un groupe, du coup? Ou bien c'est plus subtil que ça?
Revenir en haut Aller en bas
gerard35
Modérateur global
Modérateur global
avatar

Nombre de messages : 6494
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: Est-ce normal?   Lun 29 Mai 2017, 10:53

t'as peut être cliqué sur l’œil au temps 0 ? je vois que çà

perso, j'évite de mettre une action immédiate au temps 0 d'un groupe
Revenir en haut Aller en bas
http://geranim.free.fr/
akaspy
Accro
Accro
avatar

Nombre de messages : 127
Date d'inscription : 06/03/2017

Message Sujet: Re: Est-ce normal?   Lun 29 Mai 2017, 12:33

c'est possible vu le temps que j'ai passé à essayer des solutions.

Ok je garde ça en tête pour la suite. Et je vais refaire cette partie de l'anim pour que ce soit "propre".

Merci
Revenir en haut Aller en bas
Contenu sponsorisé




Message Sujet: Re: Est-ce normal?   

Revenir en haut Aller en bas
 
Est-ce normal?
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Gpsmap 62s waas ou normal
» Debit normal en VDSL2 ??
» [Résolu]mon bureau (bis)
» interrogation sur comodo firewall
» [Résolu] IE8 coupure de courant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug-
Sauter vers: