compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Problème de lien avec Roll-over dans menu

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
stefan3
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 18/12/2006

Message Sujet: Problème de lien avec Roll-over dans menu   Lun 18 Déc 2006, 18:17

Bonsoir ! Very Happy
Votre logiciel me parraissait génial, jusqu'à ce que je tombe sur un os. Peut-être pourrez-vous m'aider.
J'ai passé pas mal de temps à mettre au point un menu à l'aide d'E-anim, à base de roll-overs qui font apparaître textes et images. Jusque là, tout allait bien, mes 14 boutons fonctionnaient parfaitement, j'ai ensuite assigné à chaque bouton une commande de renvoi vers des pages web, et là, c'est le drame... Shocked
Tout d'abord, en lançant mon menu dans E-anim, un des boutons est en permanence "ouvert" (survolé), l'image et le texte associés apparaissent donc dès le début. Ensuite, lorsque j'ai converti mon menu en swf, ce problème était parti, mais un autre est apparu : aucun lien ne fonctionne, alors qu'ils marchent très avec la version phi.
Mon menu est visible ici : http://x.ebon.9online.fr/pp.htm
J'espère qu'il y a un moyen de corriger ça sans tout refaire, ça serait génial. Merci de me venir en aide ! Smile
Revenir en haut Aller en bas
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Lun 18 Déc 2006, 18:25

Tu a appliquer le lien sur tout le bouton?
:star: Romain
Revenir en haut Aller en bas
stefan3
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 18/12/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Lun 18 Déc 2006, 18:40

J'ai juste cliqué sur le bouton, puis cliqué sur l'icone "ajouter une action programmée"...
Revenir en haut Aller en bas
stefan3
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 18/12/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Lun 18 Déc 2006, 18:41

D'ailleurs, quand je lance le menu avec e-anim ( version phi ), les roll-overs fonctionnent et quand je clique une fenêtre s'ouvre m'indiquant la redirection vers une page web. Shocked
Revenir en haut Aller en bas
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Lun 18 Déc 2006, 19:42

Shocked

Oui en effet,
peut tu mettre a disposition le ficher phi et les images stp.

:star: Romain
Revenir en haut Aller en bas
stefan3
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 18/12/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Lun 18 Déc 2006, 20:24

Voilà, je les ai mis en zip ici : http://x.ebon.9online.fr/menu.zip
Merci de t'intéresser à mon problème ! Very Happy
Revenir en haut Aller en bas
stefan3
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 18/12/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Lun 18 Déc 2006, 20:39

Dans la version de menu que je viens de te proposer, j'ai dû tenter de mettre une action sur le bouton "images" et sur le même bouton survolé, juste pour essayer, mais ça ne marchait pas non plus. Par contre tous les autres boutons n'ont qu'une action sur leur bouton principal. ( je ne sais pas si je suis clair dans tout ce que je dis... Laughing )
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Mar 19 Déc 2006, 04:07

stefan3 a écrit:
Dans la version de menu que je viens de te proposer, j'ai dû tenter de mettre une action sur le bouton "images" et sur le même bouton survolé, juste pour essayer, mais ça ne marchait pas non plus. Par contre tous les autres boutons n'ont qu'une action sur leur bouton principal. ( je ne sais pas si je suis clair dans tout ce que je dis... Laughing )
En fait, il s'agit d'un problème classique.

Dans l'export Falsh, les roll-over n'acceptent pas les actions.

- Que doit-on faire ?

Transformer les roll-over (2 états) en boutons (4 états)

- Comment faire ?

1 - double clic sur chaque bouton
=> la barre 'bouton' apparait - avec 2 boutons 'états'
2 - clic sur le bouton 'transformer en bouton'
=> 4 boutons états s'affichent

-----------------------

Ici, j'ai fais le test, le lien fonctionne dès que le roll-over est transformé en bouton.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Mar 19 Déc 2006, 16:00

Romain, je uis déslé de te dire ça, mais tu arrive trop tard Razz

Oui, effectivement, c'est un problème que j'avais eu il y à bien longtemps quand je faisais le menu du site mon collège.

Le principal, cest que ça marche Very Happy

:star: Romain

PS: j'aime bien ton menu, il est classe avec les petites images
Revenir en haut Aller en bas
stefan3
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 18/12/2006

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Mar 19 Déc 2006, 18:04

Bonsoir ! Very Happy
Grand merci à toi Phildes ! Je viens de faire un petit essai et ça m'a tout l'air de marcher à merveille ! Serais-tu insomniaque pour répondre à 4 heures du mat. ?! Shocked En tous les cas, je vois que le "service après vente" est assuré avec panache ! Remercie de ma part "The Virus" pour avoir eu la bonne idée de faire ce forum !
Un grand merci aussi à toi Romain pour t'être penché sur mon cas ! Wink
Et merci pour le compliment sur mon menu. Si tout va bien, je le mettrai sur mon site : http://stefan3.over-blog.com . Vous y serez les bienvenus !
Je m'en vais corriger tout ça, à plus !
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème de lien avec Roll-over dans menu   Mar 19 Déc 2006, 20:21

stefan3 a écrit:
Bonsoir ! Very Happy
Grand merci à toi Phildes ! Je viens de faire un petit essai et ça m'a tout l'air de marcher à merveille ! Serais-tu insomniaque pour répondre à 4 heures du mat. ?! Shocked En tous les cas, je vois que le "service après vente" est assuré avec panache ! Remercie de ma part "The Virus" pour avoir eu la bonne idée de faire ce forum !
Un grand merci aussi à toi Romain pour t'être penché sur mon cas ! Wink
Et merci pour le compliment sur mon menu. Si tout va bien, je le mettrai sur mon site : http://stefan3.over-blog.com . Vous y serez les bienvenus !
Je m'en vais corriger tout ça, à plus !
Pour le 4 haure du mat', c'est que je suis un peu surbooké study study study
Mais que des choses sympa à faire... Alors cheers

A bientôt

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: Problème de lien avec Roll-over dans menu   Aujourd'hui à 04:51

Revenir en haut Aller en bas
 
Problème de lien avec Roll-over dans menu
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» problème de lien avec un nouveau membre
» Problème de lien avec une frame dans IE
» Comment créer un lien avec la possibilité qui s'ouvre dans une nouvelle fenêtre ?
» Enorme problème avec la barre de menu
» Problème avec le tuto de menu déroulant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Comment faire :: Sujets résolus ou sans suite-
Sauter vers: