compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 je dois être bête!!!

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
aurelien
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 8
Age : 41
Localisation : france, region centre
Date d'inscription : 23/01/2007

Message Sujet: je dois être bête!!!   Mar 23 Jan 2007, 16:44

ayant récement intallé eanim sur une kubuntu 6.06. j'ai 2 questions pour lesquel je suis incapable de trouver un solution sur ce forum, ou en regle general sur les forum qui parle de swf.

je souhaite simplement entrer un url de destination d'un bouton avec des variable. soit :" ./xvb.com?ap=os".
a chaque fois, eanim ne semble pas vouloir entendre de "?" dans l'url.
j'ai essayé de faire un semblant de progarmme actionscript, mais c'est encore une langue que je ne maitrise pas.

D'autre part, pour une plus simple utilisation, je me demande de quel maniére est il possible de changer l'encodage du eanim. en natif j'utilise utf8, donc à l'affichage, pb d'accent. et comment lancer eanim, sans passer systématiquement par ./linux_run.sh qui necessairement me demande de lui refournir l'adresse de jre.

dans l'attente. merci
Revenir en haut Aller en bas
http://oscim.fr
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: je dois être bête!!!   Mar 23 Jan 2007, 18:49

Pour la variable, tu ne doit pas la mettre dans l'url où se trouve la page (a moin d'utiliser php). Tu doit la metre sur l'url de ton anim....

Pour l'unicode, je ne peut pas te répondre, je travaille trés peut sous linux....

:star: Romain

Revenir en haut Aller en bas
aurelien
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 8
Age : 41
Localisation : france, region centre
Date d'inscription : 23/01/2007

Message Sujet: Re: je dois être bête!!!   Mer 24 Jan 2007, 10:21

effectivement, je code la totalité en php.

toutefois la variables est recupéré aprés par php, qui en deduit la page à afficher. pour l'affichage, l'ensemble des données passe par GET.

merci à romain

depuis hier, petite évolution. j'arrive a passer la fin de l'url, :
"?ap=os". mais la premiére partie avant "?" ne veut toujours pas passer.

pour l'unicode pas vraiment le temps de chercher...
Revenir en haut Aller en bas
http://oscim.fr
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: je dois être bête!!!   Mer 24 Jan 2007, 11:55

Citation :
pour l'unicode pas vraiment le temps de chercher...
Pour l'unicode, c'est une correction à ajouter dans le programme E-Anim lui-même.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
aurelien
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 8
Age : 41
Localisation : france, region centre
Date d'inscription : 23/01/2007

Message Sujet: Re: je dois être bête!!!   Mer 24 Jan 2007, 16:09

Pour l'unicode, c'est une correction à ajouter dans le programme E-Anim lui-même.

ok, bien compris. dans quel fichier je dois apporter une correction.
Revenir en haut Aller en bas
http://oscim.fr
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: je dois être bête!!!   Mer 24 Jan 2007, 17:50

Mais, tu met ta variable dans ton URl de la page php, tu récupére la variable et tu veut la donné à Flash?

:star: Romain
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: je dois être bête!!!   Mer 24 Jan 2007, 19:15

aurelien a écrit:
Pour l'unicode, c'est une correction à ajouter dans le programme E-Anim lui-même.

ok, bien compris. dans quel fichier je dois apporter une correction.
Tu sais programmer en Java ?

Si c'est le cas, tu dois modifier "PhFile_S.java" - dans "new String(XXX);" tu mets un second paramètre : "UTF-8"

Ce qui donne :
Code:
static public String read(String nom, boolean affMessage) throws IOException
   {
      byte[] tab = readBytes(nom, affMessage);
      return (tab!=null)? new String(tab,"UTF-8"):null;
   }

Tu fais la même chose dans la method "read()" de "txtaff_S"

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
aurelien
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 8
Age : 41
Localisation : france, region centre
Date d'inscription : 23/01/2007

Message Sujet: Re: je dois être bête!!!   Mer 24 Jan 2007, 19:41

je n'ai pas encore toucher au java, je vais jetter un coup d'oeil.

cela dis, ca ne m'inquité pas trop.

merci de la rapidité de ta réponse.
Revenir en haut Aller en bas
http://oscim.fr
aurelien
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 8
Age : 41
Localisation : france, region centre
Date d'inscription : 23/01/2007

Message Sujet: Re: je dois être bête!!!   Mer 24 Jan 2007, 20:09

aprés un rapide test. ok pour PhFile_S.java.

pas de pbs.

j'ai un doute pour "txtaff_S". j'ai mis
return new String(txtB,"UTF-8"); à la ligne 99.

apres verif ca passe pas.

mais tu parle de methode read. ok

mais annoncé ligne 76 :
static public String read(String nom, boolean affMessage)
et ligne 132: même si je ne vois pas bien ou le mettre
static public String read(String nom)

quqle details de plus ???[/i]
Revenir en haut Aller en bas
http://oscim.fr
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: je dois être bête!!!   Jeu 25 Jan 2007, 01:06

aurelien a écrit:
aprés un rapide test. ok pour PhFile_S.java.

pas de pbs.

j'ai un doute pour "txtaff_S". j'ai mis
return new String(txtB,"UTF-8"); à la ligne 99.
Chez moi c'est "ret = new String(txtB,"UTF-8");" en ligne 110.

Citation :
apres verif ca passe pas.
En fait, je ne vois pas très bien ce que tu as fais, car dans ma version je n'ai rien en ligne 99 dans "txtaff_S.java"

Citation :
mais tu parle de methode read. ok

mais annoncé ligne 76 :
static public String read(String nom, boolean affMessage)
et ligne 132: même si je ne vois pas bien ou le mettre
static public String read(String nom)

quqle details de plus ???[/i][/quote]
Désolé, j'ai trop d edifférence avec ta version. je ne peux pas t'aider.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
aurelien
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 8
Age : 41
Localisation : france, region centre
Date d'inscription : 23/01/2007

Message Sujet: Re: je dois être bête!!!   Jeu 25 Jan 2007, 09:34

Pour reprendre simplement. je n'ai fais qu'apliquer ta methode qui consiste à ajouter un argument à fichier.

"txtaff_S.java":
lg 76 debut methode read
lg 100 fin metho
lg 99 originale return new String(txtB);
modif originale return new String(txtB,"UTF-8");

idem pour PhFile_S.java.
. resultat null

Désolé, j'ai trop d edifférence avec ta version. je ne peux pas t'aider.:
C'est pas grave .

pour ce qui est de la eanim, v 6.04.

eh bien voila. merci. et tant pis
Revenir en haut Aller en bas
http://oscim.fr
Invité
Invité



Message Sujet: Re: je dois être bête!!!   Dim 13 Jan 2008, 20:20

Bonjour,

J'ai le même problème d'accent (sous Ubuntu 7.10), qui rend e-anim quasiment inutilisable... Sad

J'ai réalisé les deux modifications indiquées, mais ce n'est toujours pas mieux.

Merci d'avance ! Smile
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: je dois être bête!!!   Dim 13 Jan 2008, 21:49

nicozzz a écrit:
Bonjour,

J'ai le même problème d'accent (sous Ubuntu 7.10), qui rend e-anim quasiment inutilisable... Sad

J'ai réalisé les deux modifications indiquées, mais ce n'est toujours pas mieux.

Merci d'avance ! Smile
Quel problème ?

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Invité
Invité



Message Sujet: Re: je dois être bête!!!   Lun 14 Jan 2008, 16:36

aurelien a écrit:
D'autre part, pour une plus simple utilisation, je me demande de quel maniére est il possible de changer l'encodage du eanim. en natif j'utilise utf8, donc à l'affichage, pb d'accent.
Tous les accents dans l'interface sont remplacés par un ?, et dans ce qu'on réalise après avoir été enregistré (puis visualisé après export, ou réouvert).
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: je dois être bête!!!   Lun 14 Jan 2008, 20:02

nicozzz a écrit:
aurelien a écrit:
D'autre part, pour une plus simple utilisation, je me demande de quel maniére est il possible de changer l'encodage du eanim. en natif j'utilise utf8, donc à l'affichage, pb d'accent.
Tous les accents dans l'interface sont remplacés par un ?, et dans ce qu'on réalise après avoir été enregistré (puis visualisé après export, ou réouvert).
Quelle version utilsies-tu ?
Voir le menu "Aide/Au sujet de E-Anim"

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: je dois être bête!!!   Aujourd'hui à 06:00

Revenir en haut Aller en bas
 
je dois être bête!!!
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» que dois-je faire apres avoir fait un scan avec hijckthis
» A qui dois-je m'adresser pour un forum abandonné par son admin ?
» mon registrar ne propose pas de gestion de CNAME!! que dois-je faire?
» comment dois je faire pour recevoir par email tous les message mis sur mon forum
» vas où tu veux, meurs ou tu dois.

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Pour ce Forum :: Fonctionnement du forum-
Sauter vers: