compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Musique question...

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
maugun
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 25/01/2007

Message Sujet: Musique question...   Mar 30 Jan 2007, 16:16

Bonjour,

Je voudrais faire dans mon anim un bouton qui dès qu'on clique dessus lance à la fois l'anim, mais aussi une musique de fond.

Malheureusement pour moi je n'y arrive pas, donc je me suis mis à faire quelques recherches sur le fofo et je suis tombé sur ça :

El'vieux a écrit:

pour le faire sur votre site ou votre PC:
modifier:
ouvrir le groupe "depart" et au temps 2 ouvrir actionscript:
les 2 premières lignes:
Citation :

_root.chemin = "http://danypf.free.fr/lecteur/";
_root.chemin = _root.chemin+"chansons/";
vous y mettez le chemin que vous voulez
exemple sur votre PC dans votre répertoire "meschansons"
Citation :

_root.chemin ="meschansons/";
Very Happy

J'ai donc essayé de mettre

Code:
_root.chemin ="meschansons/";

dans la prog de mon bouton ce qui donnait :

Code:

Play();
_root.chemin ="musique féte richard\rock";
PlayMp3("aventurier.mp3");

Je fais vérifier, pas d'erreur, mais quand je lance l'animation, elle se lance mais pas la musique. J'attends un peu en me disant que c'est dû à un problème de chargement, mais toujours rien.

Je fais alors quelques autres tentative en essayant de modifier quelques trucs mais rien ne marche.

Alors je me remets dans mes recherches et je tombe sur ça :

admin a écrit:
//--- incrivez le nom du fichier son
soundName = "?NomDuSon";

//--- paramètres avancés (experts seulement)
sansprechargement = true;
phloop = 9999;

//--- jouer le son.
"phsound";
0; "Sound";code_40( );
code_1D( );

sansprechargement; soundName; 2; phsound; "loadSound";
code_52( );

phloop; 0;2; phsound; "start";
code_52( );

Je teste en remplaçant "NomDuSon" par "aventurier.mp3", ce qui donne ceci :

Code:
Play();

//--- incrivez le nom du fichier son
soundName = "aventurier.mp3";

//--- paramètres avancés (experts seulement)
sansprechargement = true;
phloop = 9999;

//--- jouer le son.
"phsound";
0; "Sound";code_40( );
code_1D( );

sansprechargement; soundName; 2; phsound; "loadSound";
code_52( );

phloop; 0;2; phsound; "start";
code_52( );

Mais pareil le son ne se lance pas (à noter que le son se trouve dans le même dossier que le .phi lorsque je teste ça).
J'essaie avec "sansprechargement = false;" mais rien à faire ça ne marche toujours pas. Sad


Pouvez vous m'aider s'il vous plaît ? Car là je ne sais plus quoi faire.
Revenir en haut Aller en bas
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: Musique question...   Mar 30 Jan 2007, 17:34

Le dernier code que tu a trouvé servait avant. tu peut l'utiliser si tu le souhaite; Dès lors, Phildes nous a fait un Macro : PlayMp3() et StopMp3()
Revenir en haut Aller en bas
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: Musique question...   Mar 30 Jan 2007, 17:36

Ton chemain doit étre absolu sur tu utilise cette méthode. Sinon, je te conseil de tout metre dans le même répertoire. Se sera plus simple :p
Revenir en haut Aller en bas
maugun
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 25/01/2007

Message Sujet: Re: Musique question...   Mar 30 Jan 2007, 17:57

Merci de ta réponse, mais quand je mets :

Code:
Play();
PlayMp3("aventurier.mp3");

L'anim' se lance mais pas la musique (pourtant ils sont dans le même dossier). D'où vient le problème ?


Ps : A la fin de l'anim' j'ai mis un bouton :

Code:
Goto(0);
StopMp3("aventurier.mp3");
Revenir en haut Aller en bas
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: Musique question...   Mar 30 Jan 2007, 18:15

Attention; Cela marchera uniquement si ton animation est exportée. Ca ne marchera pas si tu utilise l'aperçu du logiciel.
Revenir en haut Aller en bas
maugun
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 25/01/2007

Message Sujet: Re: Musique question...   Mar 30 Jan 2007, 18:19

Ah !? Ok. ^^

Merci, je la teste sur mon site et j'édite en cas problème. Wink

Merci de ton aide. Wink

Edit: Bizard j'ai importé le .swf et le son .mp3 et ça marche pas. x')
Revenir en haut Aller en bas
maugun
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 25/01/2007

Message Sujet: Re: Musique question...   Mar 30 Jan 2007, 18:28

Finalement je reposte pour "upper" le topic, car si j'édite ça ne se verra pas en tant que nouveau message. xD
Revenir en haut Aller en bas
wortmy
Accro
Accro


Nombre de messages : 105
Age : 32
Localisation : le pian medoc
Loisirs : Sport Programation
Date d'inscription : 22/01/2007

Message Sujet: Re: Musique question...   Mer 31 Jan 2007, 15:41

Salut
si j'ai bien compris tu veux faire ca :




:twisted: :twisted:

Wortmy
Revenir en haut Aller en bas
http://www.wortmy.net
wortmy
Accro
Accro


Nombre de messages : 105
Age : 32
Localisation : le pian medoc
Loisirs : Sport Programation
Date d'inscription : 22/01/2007

Message Sujet: Re: Musique question...   Mer 31 Jan 2007, 15:49

bon ok je dis comment j'ai fais :twisted: :twisted:

Bouton GOTO " goto and play "

le temps ou tu arrive tu mets un rectangle transparent avec comme ation
Mp3Play( "http://www.wortmy.net/zic.mp3");
en mettant en haut de la fenetre de selection d'action sur "declenchement au temps indiquer"

et pour stop le musique
code_09( );

Voila. c pas la meilleur methode a mon avis mais ca marche Smile

Wortmy

PS: Si vous arrivez a me comprendre BRAVO !!
Revenir en haut Aller en bas
http://www.wortmy.net
Picxime
Programmeur


Nombre de messages : 1031
Age : 25
Date d'inscription : 06/01/2006

Message Sujet: Re: Musique question...   Mer 31 Jan 2007, 17:55

Je n'arrive pas a voir t'es anim????
Revenir en haut Aller en bas
maugun
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 9
Date d'inscription : 25/01/2007

Message Sujet: Re: Musique question...   Jeu 01 Fév 2007, 18:56

wortmy a écrit:
bon ok je dis comment j'ai fais :twisted: :twisted:

Bouton GOTO " goto and play "

le temps ou tu arrive tu mets un rectangle transparent avec comme ation
Mp3Play( "http://www.wortmy.net/zic.mp3");
en mettant en haut de la fenetre de selection d'action sur "declenchement au temps indiquer"

et pour stop le musique
code_09( );

Voila. c pas la meilleur methode a mon avis mais ca marche Smile

Wortmy

PS: Si vous arrivez a me comprendre BRAVO !!


Merci ! Merci beaucoup ! ^^

Maintenant ça marche. Very Happy
Revenir en haut Aller en bas
wortmy
Accro
Accro


Nombre de messages : 105
Age : 32
Localisation : le pian medoc
Loisirs : Sport Programation
Date d'inscription : 22/01/2007

Message Sujet: Re: Musique question...   Ven 02 Fév 2007, 14:07

Picxime a écrit:
Je n'arrive pas a voir t'es anim????

a c un prebleme ca mais je c pas pouquoi dsl !!!
Revenir en haut Aller en bas
http://www.wortmy.net
the virus
Co-administrateur
Co-administrateur


Nombre de messages : 3475
Age : 23
Date d'inscription : 31/12/2005

Message Sujet: Re: Musique question...   Dim 04 Fév 2007, 10:06

ok probléme résomu pour se qui est du faite de pas voir lanimation poste dans commen faire?(dans se forum)

_________________


Je donne des cours pour e-anim ou la création de site.Pour plus d'info me contacter par MP(Skype: thevirus94)
Revenir en haut Aller en bas
yradior
Accro
Accro


Nombre de messages : 300
Date d'inscription : 25/01/2007

Message Sujet: Re: Musique question...   Mar 13 Fév 2007, 21:50

moi non plus ca ne marche pas sur mon essai, pourtant j'ai mis le son dans le meme fichier, j'ai mis:
Play();
PlayMp3("donjon-repondeurs.mp3");
et ca donne ça:
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Musique question...   Mer 14 Fév 2007, 17:52

yradior a écrit:
moi non plus ca ne marche pas sur mon essai, pourtant j'ai mis le son dans le meme fichier, j'ai mis:
Play();
PlayMp3("donjon-repondeurs.mp3");
et ca donne ça:
Non pas "PlayMp3()" mais "Mp3Play( )" Wink

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: Musique question...   Aujourd'hui à 03:24

Revenir en haut Aller en bas
 
Musique question...
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» Quizz Théorie 20 questions de la Musique
» besion d'aide language html lecteur de musique !! (Résolu)
» Quel est votre style de musique???
» Plus capable de sa "foutu" musique.. désolé le terme...
» question jeu

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Comment faire :: Sujets résolus ou sans suite-
Sauter vers: