compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 test version 7.02

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
christophe_D
Programmeur


Nombre de messages : 1903
Age : 42
Localisation : Frasne (25)
Divers : papa de 5 enfants
Loisirs : programmation en tous genres, defendre le libre , linux, photo ....
Date d'inscription : 23/06/2006

Message Sujet: test version 7.02   Mer 28 Mar 2007, 13:25

alors pour ce premier test !! ( j'en sens un qui se fais deja des cheveux blanc !!)

MTASC :
c'est vrai qu'avec mon projet il "pete" un cable !! 15 lignes d'erreurs de memoire affraid

par contre avec la methode manuel : RIEN !! (un truc m'echappe !!)

donc la .... qui a raison ... c'est bien l'histoire des variables dans les function static que j'utilise dans des fonctions creer dans les ditent fonctions

il me dire aussi aussi une erreur
par exemple
dans le fichier fonct.as
base.init(); -> fonction non trouve; alors que mtasc pur lui me la trouve !!

bon autrement pour les boutons (ceci est pas un bug a proprement dit)

j'ai creer moi meme mes boutons 4 etats (pour la prochaine pre-alpha-beta-test-mouture de mon site)( pourquoi faire simple quand on peut faire complique !! tu va me dire )

donc avec plusieur texte sur le bouton
est donc moi j'ai fais decale le texte de -1 en x et -1 en y pour l'appuyer ca donne vraiment l'impression que le texte est colle au bouton , mais ca c'est un detail je pense par rapport au travail a faire avec mtasc !

mais une question me chagrine, pour le controle des erreurs MTASC tu travail comment ???
Revenir en haut Aller en bas
http://c.diot.free.fr
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: test version 7.02   Mer 28 Mar 2007, 16:45

christophe_D a écrit:
alors pour ce premier test !! ( j'en sens un qui se fais deja des cheveux blanc !!)

MTASC :
c'est vrai qu'avec mon projet il "pete" un cable !! 15 lignes d'erreurs de memoire affraid

par contre avec la methode manuel : RIEN !! (un truc m'echappe !!)

donc la .... qui a raison ... c'est bien l'histoire des variables dans les function static que j'utilise dans des fonctions creer dans les ditent fonctions

il me dire aussi aussi une erreur
par exemple
dans le fichier fonct.as
base.init(); -> fonction non trouve; alors que mtasc pur lui me la trouve !!
Oui, je vais l'ajouter. quelle est la classe de "base" ?

christophe_D a écrit:
bon autrement pour les boutons (ceci est pas un bug a proprement dit)

j'ai creer moi meme mes boutons 4 etats (pour la prochaine pre-alpha-beta-test-mouture de mon site)( pourquoi faire simple quand on peut faire complique !! tu va me dire )

donc avec plusieur texte sur le bouton
est donc moi j'ai fais decale le texte de -1 en x et -1 en y pour l'appuyer ca donne vraiment l'impression que le texte est colle au bouton
Razz Oui je sais, je me dis depuis 7 ans qu'il va falloir le faire dès que j'ai un moment.

christophe_D a écrit:
mais une question me chagrine, pour le controle des erreurs MTASC tu travail comment ???
J'ai fais mon propre compilateur.
Mais pour les classes, mon compilateur utilise les fichiers de mtasc.

Mais certaines classes ne sont pas complètes (j'ai cru comprendre que ça vient du fait que mtasc n'accepte pas la surcharge des méthodes)
Mais mon compilateur traite la "surcharge", donc il suffit d'ajouter la fonction dans la classe (c'est très vite fait Razz )

---------------------------------------------
Trois raisons m'ont poussées à faire un compilateur :
1 - pouvoir coloriser les script en fonction du "rôle" des objets
2 - traiter plusieurs erreurs (mtasc ne traite qu'une erreur à chaque fois)
3 - je prévois de faire fonctionner les programmes pour les tests dans E-Anim.

Encore merci pour ton aide précieuse (et c'est vrai que j'ai des sueurs froides :pale: )

Razz

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
 
test version 7.02
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Présentation et test d'AVG Anti-Virus Free 2013
» nouvelle version des etrex 20x, 30x [résolu]
» Offre promotionnelle : SnagIT 7.25 en version gratuite !
» Comment envoyer une détection chez avira avec Antivir 9 français - Version Classic
» [résolu]horloge test en swf

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: