compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 objet qui se déplace !!!

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2, 3, 4, 5  Suivant
AuteurMessage
nikko
Accro
Accro


Nombre de messages : 102
Date d'inscription : 13/08/2007

Message Sujet: objet qui se déplace !!!   Lun 20 Aoû 2007, 17:51

Bonjour à tous !!!

Voila je voudrais faire un truc pour povoir déplacer un objet (image)
avec les flèsche de la souris ci c'est possible !!!
et que quand on appuie sur la barre espace un groupe s'ajoute !

Merci beaucoup de votre aide !, je sais que c'est compliqué mais j'ai besoin du code !!!
Revenir en haut Aller en bas
Beldjilali
Programmeur


Nombre de messages : 3016
Date d'inscription : 24/06/2007

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 18:36

Le plus simple c'est que tu passes par les macros qu'a mit en place DrNaBl.. Regarde dans un sous menu de CREATION
[url]
http://www.e-anim-forum.com/E-Anim-c4/Vos-creations-f15/Nouvelles-macros-f4/A-quoi-sert-ce-forum-t1811.htm
[/url]
Sinon tu vas te compliquer la vie en passant par une programmation plus compliqué alors que cet outil des macros marche trés bien
Revenir en haut Aller en bas
nikko
Accro
Accro


Nombre de messages : 102
Date d'inscription : 13/08/2007

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 19:23

ok d'accor mais commne je peux l'utilise rce macros
je ne connais pas le principer
tu sais m'expliquer ?
Revenir en haut Aller en bas
DrNaBl
Accro
Accro


Nombre de messages : 1832
Date d'inscription : 09/06/2006

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 19:25

Regarde ici, si tu ne comprend toujours pas dis le Wink:
http://infoprographiesimple.free.fr/eanim-macros/eanim-macros
J'ai une explication pour chaque macros Wink
Revenir en haut Aller en bas
Beldjilali
Programmeur


Nombre de messages : 3016
Date d'inscription : 24/06/2007

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 19:26

tu sais les utiliser mais tu ne le sais pas que tu le sais...
Je prend l'exemple de ton lecteur mp3 dans ta signature. Pour faire lecture, tu as fais mp3play(paramètres...) et bien ce mot est une macro.
Le principe est simple

(meme si personnellement je m'en sert pas souvent je le recommande)
Revenir en haut Aller en bas
nikko
Accro
Accro


Nombre de messages : 102
Date d'inscription : 13/08/2007

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 19:27

ben , non je comprend toujour pas !
vous savez pas me dire ou je met le macro
et coment je mai la classe à mon image ....

Merci de votre aide
Revenir en haut Aller en bas
Beldjilali
Programmeur


Nombre de messages : 3016
Date d'inscription : 24/06/2007

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 19:36

nikko a écrit:
ben , non je comprend toujour pas !
vous savez pas me dire ou je met le macro
et coment je mai la classe à mon image ....

Merci de votre aide
Laughing
tu n'as pas de class à créer.. Tu crés un groupe dans eanim, tu mets dedans une image et tu donnes un nom à ton groupe. Une fois que c'est fait, tu mets une action et mettant dans la case programme la ligne de la macros qui va correspond à ce que tu essais de faire.
Revenir en haut Aller en bas
nikko
Accro
Accro


Nombre de messages : 102
Date d'inscription : 13/08/2007

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 19:43

je fait ce que tu me dit mais sa marche pas !
page de test
- http://anonyme.archive-host.com/test_a59hc3elix.swf
mon .phi
- http://anonyme.archive-host.com/test_7v15wwrfua.phi
mon image à déplacer
- http://anonyme.archive-host.com/stop_62uyep4spp.png
le macros
Code:
testTouche= keyIsDown(38);//38 correspond a la touche de la flèche haut du clavier.
if(testTouche)// si la touche est appuyée
{
//instructions
}
else// sinon si la touche n'est pas appuyée
{
//instructions
}

ce que je veux faire
- http://www.e-anim-forum.com/comment-faireproblemebug-c5/Mtasc-f24/Exemple-MTASC-pur-deplacer-une-image-avec-le-clavier-t792.htm?highlight=clavier
- http://s154254984.onlinehome.fr/swf/jeu2/exemple.html
Revenir en haut Aller en bas
Beldjilali
Programmeur


Nombre de messages : 3016
Date d'inscription : 24/06/2007

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 20:12

as-tu téléchargé le fichier ZIP sur le site de DrNaBl avec la mise à jour d'un fichier de Eanim pour ces macros?

le fichier phi est vide.. aucune image. les exemples que tu m'as donné sont fait sous MTASC. si tu veux on peut partir sur cette programmation (elle est un peu plus chiante à mettre en oeuvre que les macro)
Revenir en haut Aller en bas
DrNaBl
Accro
Accro


Nombre de messages : 1832
Date d'inscription : 09/06/2006

Message Sujet: Re: objet qui se déplace !!!   Lun 20 Aoû 2007, 20:17

C'est normal que rien ne se passe, déjà as-tu téléchargé le fichier macro ? C'est celui ci:
http://infoprographiesimple.free.fr/eanim-macros/macros_sys.zip
Décompresse le dans dossier doc/macros/ du dossier e-anim.
Ensuite ceci fait, ton code est tout a fait juste mais c'est normal que rien ne se passe, tu dois remplacer "//instruction" parce que tu veux qui se passe, si le groupe qui contient ton l'image que veut déplacer s'appelle "hero" fait:

Code:
_root.posX=_root/hero._x;
_root.posY=_root/hero._y;

testTouche= keyIsDown(38);//38 correspond a la touche de la flèche haut du clavier.

if(testTouche)// si la touche est appuyée
{
_root.posX=_root.posX-5;
}

_root.hero._x;=_root.posX;
_root.hero._y;=_root.posY;
Revenir en haut Aller en bas
nikko
Accro
Accro


Nombre de messages : 102
Date d'inscription : 13/08/2007

Message Sujet: Re: objet qui se déplace !!!   Mar 21 Aoû 2007, 17:41

sa marche toujours pas il me dit "erreur le script ne peux pas fonctionner " et il me montre le panneau avec ton code !
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: objet qui se déplace !!!   Mar 21 Aoû 2007, 19:10

nikko a écrit:
sa marche toujours pas il me dit "erreur le script ne peux pas fonctionner " et il me montre le panneau avec ton code !
oui, il faut supprimer les ';' mal placés : study
_root.hero._x;=_root.posX;

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
nikko
Accro
Accro


Nombre de messages : 102
Date d'inscription : 13/08/2007

Message Sujet: Re: objet qui se déplace !!!   Mar 21 Aoû 2007, 19:34

sa marche toujours pas
voila ce que je fais
- j'ajoute un groupe
- j'ajoute mon image dans le groupe
- je renomme le groupe en "hero"
- je retourne sur l'animation de base
- j'ajoute une action au groupe qui se déclanche immédiatement
avec le code sans les ";"
- j'enregistre, j'upload et rien ne marche !
Revenir en haut Aller en bas
Beldjilali
Programmeur


Nombre de messages : 3016
Date d'inscription : 24/06/2007

Message Sujet: Re: objet qui se déplace !!!   Mar 21 Aoû 2007, 20:32

pour renommer le groupe, tu dois d'abord retourner sur l'ecranDeBase puis tu ajoutes l'action
Revenir en haut Aller en bas
nikko
Accro
Accro


Nombre de messages : 102
Date d'inscription : 13/08/2007

Message Sujet: Re: objet qui se déplace !!!   Mar 21 Aoû 2007, 20:36

sa marche toujours pas ....
Revenir en haut Aller en bas
Contenu sponsorisé




Message Sujet: Re: objet qui se déplace !!!   Aujourd'hui à 04:50

Revenir en haut Aller en bas
 
objet qui se déplace !!!
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 5Aller à la page : 1, 2, 3, 4, 5  Suivant
 Sujets similaires
-
» objet qui se déplace !!!
» Mise en place des objets
» Passer un objet devant les autres (ou derrière)
» Satellite_Heart || Don't stay at her place.
» [Résolu] disparition de place sur le disque dur

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: