compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Le problème qui gâche tout... ^^

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2, 3, 4, 5, 6, 7, 8, 9  Suivant
AuteurMessage
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Le problème qui gâche tout... ^^   Mer 23 Jan 2008, 14:49

Bonjour a tous.

Me revoila emportant (encore et toujours) quelques petits problèmes sans réponses (Pour l'instant, je l'espère!) sunny .

Je m'était lancé dans un petit projet de jeu. L'objet est draggable et il faut l'enmener en terre inconnu :pirat: .

J'ai fais l'accueil, les règles, et je me suis attaqué en premier niveau...
Premier niveau fini et, premier test!

Et comme on peut s'en douter (puisque je post dans la section problème/bug Laughing ) un petit bug interviens, empêchant l'action qui aurait du se produire lors de la collision :pale: .

J'ai testé (et re-testé) des manip', des façon différentes d'utiliser la collision, je ne trouve pas le problème :pale: .

Alors aujourd'hui je m'en remet à vous tous pour m'éclairer et me trouver
d'où vien ce ("Censuré") bug... :twisted: .

Merci de vos réponses, je joinds rapidement mon dossier a ce sujet.

Seboy.
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Mer 23 Jan 2008, 14:56

Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 10:41

Problème difficile a déceler? Smile
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 14:11

seboy1 a écrit:
Problème difficile a déceler? Smile
En fait, c'est surtout se message qui a été difficile à décelé.
J'ignore pourquoi, mais je n'avais les indicateurs 'nouveau messages' pointant ce sujet.

Je n'arrive pas à télécharger ton programme.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 14:49

Bonjour.

Oui, j'ai eu un problème pour mettre mon dossier en téléchargement (sur e-anim il y a une erreur) j'ai donc utilisé megaupload.

Voici le lien :
megaupload.com/fr TYR82F2U
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 15:44

[quote="seboy1"]Bonjour.

Oui, j'ai eu un problème pour mettre mon dossier en téléchargement (sur e-anim il y a une erreur) j'ai donc utilisé megaupload.

Voici le lien :
megaupload.com/fr TYR82F2U[/wysi_quote]

Tout d'abord, les noms des images ne doivente pas contenir ni d'espace, ni de caractères spéciaux (accent, ç, +, -, ?...)
Seulement a-z, A-Z, 0-9 et '_' (souligné)

Sur internet on recommande même de n'utiliser qu des minuscules.

------------------------------------
Ensuite, je ne trouve pas : _root.Lakitu parmis les Pieces composants l'anim.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 17:24

j'ai enlevé les espaces à tous les objets, j'ai renommé le Lakitu en lakitu(donc j'ai modifier les nom dans l'action script), compilation, et toujours aucunes actions lors d'une collision...
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 17:33

je suis en train de regarder, j'avais pas vu ta question...
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 17:39

deux choses:

1) tu dois obligatoirement mettre une static main function();
(ya pas dans ton code)

2)
je suis moins sûr là, mais:
je crois tu peux pas mettre if ----> else if, mais if---->else suivi de ou/et.
Je connais pas la syntaxe juste. Si tu as deja vu cette syntaxe, alors je vois pas


Dernière édition par le Jeu 24 Jan 2008, 17:46, édité 1 fois
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 17:44

C'est probable.

J'ai vu cette méthode en C alors j'ai tenté ma chance Very Happy
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 17:47

j'ai edité

il manque une fonction obligatoire:

static funtion main ();

essaie ca:
Code:

   static function main(mc:MovieClip):Void{

ca devient dans ton action
->mario.main();

aussi les commentaires, il me semble 2 // pas 1/ en mtasc

un programmeur pourra te renseigner mieux que moi

son code, sans corrections:
Code:

class Mario{
   

   
   
   static function ecranDeBase1(mc:MovieClip):Void{
      /* <id method> <1200493282720/0> ne pas supprimer ni déplacer ce commentaire / don't supress or move this comment.*/
      if(_root.mur1.hitTest(_root.Lakitu)){
         _root.gotoAndStop(1);
      }
      else if(_root.Lakitu.hitTest(_root.mur2)){
         _root.gotoAndStop(1);
      }
      else if(_root.mur3.hitTest(_root.Lakitu)){
         _root.gotoAndStop(1);
      }
      else if(_root.mur4.hitTest(_root.Lakitu)){
         _root.gotoAndStop(1);
      }
      else if(_root.mur5.hitTest(_root.Lakitu)){
         _root.gotoAndStop(1);
      }
      else if(_root.ennemi1.hitTest(_root.Lakitu)){
         _root.gotoAndStop(1);
      }
      else if(_root.sortie.hitTest(_root.Lakitu)){
         _root.play();

      }
      /* ecrire ici / write here */
   }
}
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 17:59

Mon code actionscript deviens :
Code:
class Mario{
   

   
   
   static function main(mc:MovieClip):Void{
      /* <id method> <1200493282720/0> ne pas supprimer ni déplacer ce commentaire / don't supress or move this comment.*/
      if(_root.mur1.hitTest(_root.Lakitu)){
         _root.gotoAndStop(1);
      }
      else (_root.Lakitu.hitTest(_root.mur2)){
         _root.gotoAndStop(1);
      }
      
      /* ecrire ici / write here */
   }
}
je test donc la collision avec mur1 et mur2 pour l'instant et sur lakitu en temps 3 (action permanente depuis le temps indiqué) j'ai:

/* <1200493282720/0> ne pas supprimer ni déplacer ce commentaire / don't supress or move this comment.*/
->mario.main();

La collision n'effectue toujours aucune action =s
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:02

Me suis tromper:
_root.Lakitu j'ai enlevé la majuscule ca donne donc _root.lakitu

mais toujours aucune action. :'(
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:10

les commentaires c'est // pas /

je trouve le ET c'est && mais le OU c'est quoi ???

je propose pour le moment ca:
Code:

class Mario{
 

 
 
  static function main(mc:MovieClip):Void{
      //* <id method> <1200493282720/0> ne pas supprimer ni déplacer ce commentaire / don't supress or move this comment.*/
      if(_root.mur1.hitTest(_root.Lakitu)){
        _root.gotoAndStop(1);
      }
      if (_root.Lakitu.hitTest(_root.mur2)){
        _root.gotoAndStop(1);
      }
     
      //* ecrire ici / write here */
  }
}

tu peux enlever tes commentaires pour voir aussi
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:18

le OU c'est || (ctrl alt 6)
Revenir en haut Aller en bas
Contenu sponsorisé




Message Sujet: Re: Le problème qui gâche tout... ^^   Aujourd'hui à 09:38

Revenir en haut Aller en bas
 
Le problème qui gâche tout... ^^
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 9Aller à la page : 1, 2, 3, 4, 5, 6, 7, 8, 9  Suivant
 Sujets similaires
-
» [Fermé] Problème search-web, antivirus et vidéos qui ne chargent pas
» Problème moral
» Problème avec une iframe sous Chrome
» Barre de défilement qui n'apparaît pas tout de suite...
» Problème avec les liens (visible par les admin uniquement et je veux que tout le monde les vois)

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: