compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Le problème qui gâche tout... ^^

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3, 4, 5, 6, 7, 8, 9  Suivant
AuteurMessage
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:20

A oui merci,
tu es pas obligé de le mettre, ca revient au meme pour le moment.
Ca joue ou pas ?
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:27

je mettrais pas une action permanente, je mettrais l'objet déclanche l'action et tu ajoutes un temps 1

le code
Code:

class Mario{
 

 
 
  static function main(mc:MovieClip):Void{
   
      if(_root.mur1.hitTest(_root.Lakitu)) || (_root.Lakitu.hitTest(_root.mur2)) {
        _root.gotoAndStop(1);
       
      }


  }
}

sinon je peux pas t'aider plus
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:43

Non toujours rien Sad
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:48

tu as plusieurs éléments dans ton groupe mur2 ? normalement pour la collision, un seul élément dans un groupe; si tu as 2 éléments, ca signifie 2 groupes.
je vais regarder ton phi, mais j'atteins les limites de mes connaissances en programmation là.
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:56

Merci d'y préter attention chris. Smile

J'ai mis un seul élément pour chaque groupe (sauf pour le fantome).
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 18:58

je vois pas l'action qui appelle ta fonction dans le groupe mur2
Code:

->mario.main();

je trouve pas le groupe Lakitu, je vois un Lakitu_gif seulement.
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 19:11

le fichier que j'ai mi a télécharger au début du sujet n'est pas le bon.

Je met très prochainement celui avec les modifications.
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Jeu 24 Jan 2008, 21:42

seboy1 a écrit:
j'ai enlevé les espaces à tous les objets, j'ai renommé le Lakitu en lakitu...
Donc ça ne pouvait pas fonctionner, mais c n'est pas un bug de E-Anim.
Il y en a d'autres Razz Mais inutile d'en trouver là où n'y en a pas.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
christophe_D
Programmeur


Nombre de messages : 1903
Age : 42
Localisation : Frasne (25)
Divers : papa de 5 enfants
Loisirs : programmation en tous genres, defendre le libre , linux, photo ....
Date d'inscription : 23/06/2006

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 25 Jan 2008, 13:44

chris_c a écrit:
je vois pas l'action qui appelle ta fonction dans le groupe mur2
Code:

->mario.main();

je trouve pas le groupe Lakitu, je vois un Lakitu_gif seulement.

pourtant le la ligne suivante ->mario.main(); contient une erreur !!!

c'est ->mario:main(); avec 2 points , pour appeler une fonction action Script depuis e-anim

par ailleur appeler une fonction main() est une erreur car elle est appele au demarrage !! en stipulant - main() au compilateur MTASC
Revenir en haut Aller en bas
http://c.diot.free.fr
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 25 Jan 2008, 18:39

oui mais en pratique:
on écrit
->mario.
ca marche, regarde les tutos de Beldjilali.
C'est pas des erreurs vu que ca fonctionne.


sinon pour les else if, j'ai vu que ca existe, tu peux en mettre.
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 25 Jan 2008, 22:12

chris_c a écrit:
oui mais en pratique:
on écrit
->mario.
nan-nan-nan, si Christophe te dis qu'il faut mettre ':', tu peux avoir confiance Razz Tu mets ':'

Effectivement avec un point ça peut marcher parfois, ou non... Avec ':' ça doit marcher tout le temps.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 25 Jan 2008, 23:55

Mais ca aide pas Seboy1.




et je veux pas faire du bla bla dans ce post.
Revenir en haut Aller en bas
christophe_D
Programmeur


Nombre de messages : 1903
Age : 42
Localisation : Frasne (25)
Divers : papa de 5 enfants
Loisirs : programmation en tous genres, defendre le libre , linux, photo ....
Date d'inscription : 23/06/2006

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 26 Jan 2008, 00:06

Admin a écrit:
chris_c a écrit:
oui mais en pratique:
on écrit
->mario.
nan-nan-nan, si Christophe te dis qu'il faut mettre ':', tu peux avoir confiance Razz Tu mets ':'

Effectivement avec un point ça peut marcher parfois, ou non... Avec ':' ça doit marcher tout le temps.

Phildes

je confirme !!

travaillant depuis 1 ans environs le couple e-anim / Matsc sous linux
je n'utilise pas la console mtasc d'eanim car probleme de fichier executable sous linux et windows

tous les test que j'ai ont toujours fonctionner avec la methode ci dessus

mais un gros detail qui a sont importance , et la aussi bien sous linux que windows

ma_fonction() et Ma_fonction() son totalement differente !!! mtasc et sensible a la casse , c'est a dire qu'il fais la difference en les majuscules et minuscule

de meme qu'utilise la fonction main() me derange , car c'est la fonction d'initialisation du "programme" actionscript
voili
Revenir en haut Aller en bas
http://c.diot.free.fr
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 26 Jan 2008, 00:14

grrrrrrrrr ca aide pas à régler notre problème, vu que

1) avec un . ou : ca fonctionne de toute facon et sans bugs.
2) main(), je savais mais ca modifie en rien le déroulement du programme, ca assure que c'est bien enclanché.
3) ca serait mieux de jeter un oeil sur le reste du code, pour voir où ca cloche.
4) je suppose qu'on est pas assez mature pour programmer
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 26 Jan 2008, 00:24

chris_c a écrit:
Mais ca aide pas Seboy1.




et je veux pas faire du bla bla dans ce post.
Désolé, je fais effectivement du blabla, car je viens de tomber sur un vilain bug !
Et il me prend la tête.

Désolé :pale:

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: Le problème qui gâche tout... ^^   Aujourd'hui à 05:00

Revenir en haut Aller en bas
 
Le problème qui gâche tout... ^^
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 2 sur 9Aller à la page : Précédent  1, 2, 3, 4, 5, 6, 7, 8, 9  Suivant
 Sujets similaires
-
» [Fermé] Problème search-web, antivirus et vidéos qui ne chargent pas
» Problème moral
» Problème avec une iframe sous Chrome
» Barre de défilement qui n'apparaît pas tout de suite...
» Problème avec les liens (visible par les admin uniquement et je veux que tout le monde les vois)

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: