compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Le problème qui gâche tout... ^^

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3, 4, 5, 6, 7, 8, 9  Suivant
AuteurMessage
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 01 Fév 2008, 22:46

Bonjour a tous et à toute! Very Happy

J'ai suivi tous vos précieux conseils et me voila fin prèt pour laisser allez mon imagination. Et mon imagination n'a pas chaumé Laughing !

Je me suis donc lancé dans : la création d'une console de jeu contenant plusiseurs minijeux.

J'ai fais la console, menu, etc...

J'ai commencé mon 1er minijeu: LAKITU BROSS!! (Et oui encore lui!!! Razz )
J'ai fais mon 1er niveau, et... problème :pale: .

Et bien ce problème, c'est... la collision !(et oui encore elle! tongue )

Alors je m'en remet en vous (j'ai déjà cherché de mon côté et fais quelques modifications),(Il ne devrait avoir a priori pas de problème à propos des nom des groupes/objets.) et vous remet mon dossier.

Et aussi,... pendant que vous y êtes... donnez votre avis sur les graphisme :o , Merci!! Cool

PS : tout les graphismes sont de moi SAUF la maaaaagnifique console fais par Mr. mafiacx. Cool

Merci de vos réponses,
▲Seboy1▲
megaupload.com/fr WZEGQFQS
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 01 Fév 2008, 22:58

le graphisme est excellent.

Ya un anneau qui tourne et il se passe quoi après ?
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 01 Fév 2008, 23:19

Tout d'abord, effectivement, c'est un superbe travail. Le graphisme est époustouflant !

Pour revenir à ton problème.

OK, tu fais l'action de hitTest() dans le lakitu-sur-son-petit-nuage.
Mais ton action se déclenche après un clic souris... Il faut que se soit une animation permanente.

Comment faire ?
1 - Tu ouvres l'action de ton lakitu-sur-son-petit-nuage.
=> la fenêtre de script s'affiche
2 - referme la fenêtre de script
=> il reste le cadre "action" ouvert
3 - en haut de ce cadre, clic sur le large bouton "orange" pour lire "action permanente" (il te faudra certainement 2 clics)

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 01 Fév 2008, 23:51

Tout d'abord, merci pour vos critiques sur les graphiques :rabbit: . Ca fais toujours très plaisir, Very Happy et pour ta réponse phildes.

Maintenant, lorsque je cogne contre les 4 murs, la vie diminu, et "lakitu" reviens à la bonne position! :bom:
Dernières actions qui ne fonctionnent pas ; lorsque la vie = 0, on devrait revenir au temps 2 et s'arrêter, mais la vie continu de diminuer et rien ne se passe. Ensuite, lorsque "lakitu cogne contre l'anneau, il doit aller au niveau suivant ( _root.gotoAndStop("le temps du niveau suivant"); ). Et la encore, rien ne se passe.

Pouvez-vous encore m'éclairer? Smile :rendeer:

♦Seboy1&#9830
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Ven 01 Fév 2008, 23:59

edit:
c'est normalement
_root.vies=0
pas ==
dans le guide mtasc
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 00:15

gotoAndPlay ne me sert pas puisque je veux que l'anim s'arrete au temps 2...

Donc j'ai toujours la collision qui ne se fait pas entre "lakitu" et l' "anneau" et le retour au temps 2 qui ne se fait pas lorsque _root.vies == 0 (ou _root.vie=0 Very Happy).

Seboy1.
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 00:26

je comprends mal la structure de tes groupes, je dois dire. Mais si ca fonctionne avec le nombre de vie, c'est ok...
Revenir en haut Aller en bas
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 11:38

J'ai tester quelque chose:
J'ai remplacé _root.gotoAndStop(5); par _root.messagevie_text = _global.vies--; et lorsque je cogne contre l'anneau, la vie diminu. Le problème vient donc de _root.gotoAndStop(5);
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 11:44

seboy1 a écrit:
J'ai tester quelque chose:
J'ai remplacé _root.gotoAndStop(5); par _root.messagevie_text = _global.vies--; et lorsque je cogne contre l'anneau, la vie diminu. Le problème vient donc de _root.gotoAndStop(5);
:oops: Oui !

Le gros problème de E-Anim !
Dans l'action-script, il faut ajouter 1 au n° de temps.

Pourquoi ?
la barre-de-temps de Flash commence à 1
la barre-de-temps de E-Anim commence à 0

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 12:15

Ok!

Sinon j'ai un problème.
J'aimerais que si j'ai 0 vie, j'aille au temps x, et que ma vie revienne à 3.
J'ai tenté ceci:

if(_root.vie=0){
_root.gotoAndStop(3);
_root.vies=3;
}

Mais bon ca n'a pas marché Very Happy (je ne vais pas au temps 3, et ma vie ne reviens pas a 3).

Avez-vous le bon code,

Seboy1.
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 12:18

essaie
_global.vies=3

j'ai posté avant, mais ca a été effacé
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 12:35

seboy1 a écrit:
Ok!

Sinon j'ai un problème.
J'aimerais que si j'ai 0 vie, j'aille au temps x, et que ma vie revienne à 3.
J'ai tenté ceci:

if(_root.vie=0){
_root.gotoAndStop(3);
_root.vies=3;
}

Mais bon ca n'a pas marché Very Happy (je ne vais pas au temps 3, et ma vie ne reviens pas a 3).

Avez-vous le bon code,

Seboy1.
Dans ton script, dans le 'if', ta variable "vie" n'a pas de 's', puis dans l'égalité, elle a un 's'.
Tu mets un "s" ou non à "vie" ?

Sinon, ta syntaxe me parrait correct

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
seboy1
Accro
Accro


Nombre de messages : 89
Date d'inscription : 04/01/2008

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 13:07

D'accord, j'ai corrigé le code.
Voila le code actuel:
Code:
      
      if(_root.vies=0){
      _root.gotoAndStop(2);
      _global.vies=3;      
   
      
}      

La vie dimimu, et lorsque vies = 0 , on ne retourne pas au temps 2 et la vie ne revient pas à 3...
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 13:17

on a effacé ce que j'avais mis avant....
mettre dans e-anim
une action permanente sur une forme transparente
if (vies=0){gotoandstop(2);vies=3}

avec mtasc j'ai essayé en vain
le gotoAndStop, ca a jamais marché
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Le problème qui gâche tout... ^^   Sam 02 Fév 2008, 13:39

chris_c a écrit:
on a effacé ce que j'avais mis avant....
mettre dans e-anim
une action permanente sur une forme transparente
if (vies=0){gotoandstop(2);vies=3}

avec mtasc j'ai essayé en vain
le gotoAndStop, ca a jamais marché
danbs l if, il faut mettre un comparaison : ==
if (vies==0)...

Je te conseille de conserver _root.vies ou _global.vies

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: Le problème qui gâche tout... ^^   Aujourd'hui à 09:53

Revenir en haut Aller en bas
 
Le problème qui gâche tout... ^^
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 7 sur 9Aller à la page : Précédent  1, 2, 3, 4, 5, 6, 7, 8, 9  Suivant
 Sujets similaires
-
» [Fermé] Problème search-web, antivirus et vidéos qui ne chargent pas
» Problème moral
» Problème avec une iframe sous Chrome
» Barre de défilement qui n'apparaît pas tout de suite...
» Problème avec les liens (visible par les admin uniquement et je veux que tout le monde les vois)

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: