compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Juste une question de combine... [RESOLU]

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
Carowly
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 18
Date d'inscription : 27/05/2009

Message Sujet: Juste une question de combine... [RESOLU]   Jeu 30 Juil 2009, 19:13

Bonjour bonjour!

Aujourd'hui vous allez avoir à faire à un problème que mon incompétence n'a su résoudre.
Je voudrais combiner dans une seule animation un texte qui apparait et disparait et un bouton qui enclenche et arrête de la musique.

Combien de groupes dois-je faire et dans quel(s) groupe(s) dois-je créer chacun de mes deux éléments?

Merci d'avance de votre réponse!
Carowly


Dernière édition par Carowly le Sam 01 Aoû 2009, 16:21, édité 1 fois
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Juste une question de combine... [RESOLU]   Ven 31 Juil 2009, 03:27

Carowly a écrit:
Bonjour bonjour!

Aujourd'hui vous allez avoir à faire à un problème que mon incompétence n'a su résoudre.
Je voudrais combiner dans une seule animation un texte qui apparait et disparait et un bouton qui enclenche et arrête de la musique.

Combien de groupes dois-je faire et dans quel(s) groupe(s) dois-je créer chacun de mes deux éléments?

Merci d'avance de votre réponse!
Carowly
Tu peux ne pas faire de groupe.

A - Tu fais un texte qui apparait puis disparait
B - tu ajoutes 2 bouton au temps 0.
Dans les boutons, tu mets les commandes pour lancer et arrêter la musique :
- Mp3Play("music.mp3");
- Mp3Stop();



Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Carowly
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 18
Date d'inscription : 27/05/2009

Message Sujet: Re: Juste une question de combine... [RESOLU]   Ven 31 Juil 2009, 13:35

Merci de ta réponse, Phildes mais j'ai malheureusement toujours un problème.

Le problème, c'est que j'utilise une autre méthode pour faire mes boutons, de sorte que l'on ait l'impression qu'il n'y a qu'un seul bouton.

Pour cela je place un bouton au temps 0, je le programme avec ce code:
Mp3Play("music.mp3");
Goto(1);
Stop();

Ensuite je stoppe l'animation, j'avance au temps 1, je cache le bouton avec l'oeil et je crée un autre bouton en le programmant avec ce code:
Mp3Stop( );
Goto(0);
Stop( );

Après je crée mon texte disparaissant.
Malheureusement, mon animation ne montre que le texte, même si j'ai créé celui-ci avant le bouton de la musique!
J'espère que tu peux m'aider!
Carowly
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 00:00

Carowly a écrit:
Merci de ta réponse, Phildes mais j'ai malheureusement toujours un problème.

Le problème, c'est que j'utilise une autre méthode pour faire mes boutons, de sorte que l'on ait l'impression qu'il n'y a qu'un seul bouton.

Pour cela je place un bouton au temps 0, je le programme avec ce code:
Mp3Play("music.mp3");
Goto(1);
Stop();

Ensuite je stoppe l'animation, j'avance au temps 1, je cache le bouton avec l'oeil et je crée un autre bouton en le programmant avec ce code:
Mp3Stop( );
Goto(0);
Stop( );
Bien vu cheers
C'est effectivement la methode que je trouve la plus propre pour construire un bouton-multi-action sunny (C'est le même principe que pour les cases-à-cocher)

Il faut de placer tes 2 boutons dans un groupe. Afin qu'ils puissent tranquillement de déplacer du temps 0 au temps 1, sans perturber les autres effets de ton animations Cool

En tout cas, bravo, pour avoir trouvé si vite la solution du bouton-multi-action.

@ bientôt

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Carowly
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 18
Date d'inscription : 27/05/2009

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 00:53

J'éspère ne pas trop te décevoir en te disant que c'est la méthode que j'ai apprise par un tuto sur un forum de graphisme et que malheureusement je ne l'ai pas trouvée moi-même... ^^

Mon problème est, même avec ton aide, le même. J'ai créé mon texte, puis j'ai créé mon groupe et mes deux boutons.
Puis j'ai créé la page etc...
Le bouton est toujours absent!
Est-ce que lors de l'enregistrement il faut se situer sur l'écran de base? Car moi je reste sur l'onglet anim_:0
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 00:56

ca n'a rien à voir avec l'enregistrement, sinon je ne sais pas.
Revenir en haut Aller en bas
Carowly
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 18
Date d'inscription : 27/05/2009

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 00:59

Merci chris!
Bon bon bon... Lorsque je joue mon animation sur l'écran de base, le bouton disparait alors qu'il y est avant que je ne joue l'animation. Et lorsque je clique dessus, il ne se passe rien alors qu'il devrait changer de couleur lorsqu'il est enfoncé ou survolé.
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:02

dans NORMAL tu as mis quelque chose ?
Revenir en haut Aller en bas
Carowly
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 18
Date d'inscription : 27/05/2009

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:04

Pour les boutons? Oui, dans normal, survolé et enfoncé.
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:08

envoie à Phildes (admin) ton fichier .phi ET tes images en zip par email, il pourra t'aider, c'est un problème de construction je pense.
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:10

Carowly a écrit:
Pour les boutons? Oui, dans normal, survolé et enfoncé.
Là, ça devrait fonctionenr. Peux-tu m'envoyer ton anim - .phi + images ?
(il y a un bouton e-mail en bas de ce message)

Au fait, tu n'utilises pas de gif-animé ?

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Carowly
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 18
Date d'inscription : 27/05/2009

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:11

Non, non! D'accord je t'envoie tout ca tout de suite.
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:29

Carowly a écrit:
Non, non! D'accord je t'envoie tout ca tout de suite.
Tu as placé ton bouton sur le dernier temps... mais dans e-animl, les animation reviennent automatiquement au départ.

Il faut mettre un stop sur le temps qui comporte le bouton Very Happy

phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Carowly
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 18
Date d'inscription : 27/05/2009

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:33

Mais il me semble que c'est ce que je fais... Faut-il aussi stopper au temps 1?
Revenir en haut Aller en bas
chris_c
Accro
Accro


Nombre de messages : 8400
Age : 46
Date d'inscription : 18/11/2007

Message Sujet: Re: Juste une question de combine... [RESOLU]   Sam 01 Aoû 2009, 01:40

si tu mets un stop au temps 1, ton animation s'arrete au temps 1...sans aller plus loin. si ton bouton est au temps 30, ca ira pas.
regarde bien si tu as mis le stop dans ecran de base
Revenir en haut Aller en bas
Contenu sponsorisé




Message Sujet: Re: Juste une question de combine... [RESOLU]   Aujourd'hui à 05:37

Revenir en haut Aller en bas
 
Juste une question de combine... [RESOLU]
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» Juste une question de combine... [RESOLU]
» Question couleur lien.[RESOLU]
» Juste une simple question
» [RESOLU]Question sur les meta tags
» Des téléphones "juste pour téléphoner"

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Comment faire :: Sujets résolus ou sans suite-
Sauter vers: