compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 [Résolu] problème de débutant

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2, 3  Suivant
AuteurMessage
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: [Résolu] problème de débutant   Ven 27 Nov 2009, 18:25

Bonsoir,

je suis en pleine découverte de E Anim. Comme je ne sais pas par qui réellement commencer, j'ai décidé d'essayer de faire ce qui pourrait m'être utile rapidement.

Mon objectif est de faire varier une valeur ou une transparence par l'intermédiaire d'un curseur.

Pour ce faire j'essaye de prendre exemple sur "programmer un curseur" d'un post de janvier 2009
http://www.e-anim-forum.com/programation-f23/programmer-un-curseur-merci-fastoche-t5032.htm

Mais dès le début je rencontre un petit souçis.
Il est fait mention de
Citation :
Vs cliquez dessus bouton 3 etats

normal .....action immediate....programmer...vous mettez ce code:

enddrag(->/bouton);//de facon qu'il soit dragguable

hors je ne sais pas où placer le code:

lorsque je créé le bouton j'ai bien la possibilité de faire "action..." à partir des attributs du bouton, mais qu'en est -il pour trouver "normal .....action immédiate....programmer"?

pourrait-on m'aiguiller un petit peu?

Merci
Revenir en haut Aller en bas
Snow
Accro
Accro


Nombre de messages : 455
Age : 20
Date d'inscription : 26/07/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 18:36

tu a quelle version?

parceque avec la version classique dite "gratuite" on ne peut pas programmer

seulempent avec la FX version payante a 10 € qui vaut vraiment le coup
Revenir en haut Aller en bas
http://guerredesclans.activebb.net
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 19:24

j'ai la fx 8.04.011
Revenir en haut Aller en bas
Snow
Accro
Accro


Nombre de messages : 455
Age : 20
Date d'inscription : 26/07/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 19:28

moi j'ai la 8.04.002

heu il faut que tu fasse action et tu a le cadre programé
Revenir en haut Aller en bas
http://guerredesclans.activebb.net
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 19:43

je crois ne pas avoir été assez précis.

comment arrive t-on à cette phase de l'exemple que j'essaye de reproduire

Citation :
1etape:
Creez un bouton que vs nommez "bouton"
action immediate...programmer....vous mettez ce code:


varx=->bouton._x;
_root.message_text=varx-100;

Vous positionnez ce bouton à 100x 50y

Vs cliquez dessus bouton 3 etats

normal .....action immediate....programmer...vous mettez ce code:

enddrag(->/bouton);//de facon qu'il soit dragguable



survolé .....action immediate....programmer...vous mettez ce code:

enddrag(->/bouton);//idem


appuyé .....action immediate....programmer...vous mettez ce code:


100;50; 200;50;// 100=X, 50=Y, 200= nb pixel horizontal, //50=fin du curseur en Y
1;
0;
->/bouton;
Code_27( );//code por le drag


j'ai bien trouvé l'action du bouton mais pas le moyen d'attribuer une action au mode " normal, survolé ou appuyé"
Revenir en haut Aller en bas
Snow
Accro
Accro


Nombre de messages : 455
Age : 20
Date d'inscription : 26/07/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 19:46

ha d'acord j'ai mal lut c'est ma faute

il faut que tu clique au lieu de action sur bouton animé et dans les onglet des groupe il y a des bouton qui sont le normal survoler et appyer

la tu rajoute les action programé
Revenir en haut Aller en bas
http://guerredesclans.activebb.net
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 19:53

bien j'ai également fait cette manip.
en cliquant sur normal j'obtiens une page avec "attribut d'édition", mais lorsque je rentre une ligne de code , entre autre enddrag dès que je tape le "e" il m'envoie un message d'erreur. Et je n'ai pas trouvé d'autre endroit où taper mon code.

De plus lorsque je suis en mode animé je n'arrive plus à revenir en mode action( fenêtre de départ)

Petit point également: Pour savoir que j'ai une réponse à ce post, y a t-il un moyen plus rapide que de revenir sur la page accueil et ....
Revenir en haut Aller en bas
Snow
Accro
Accro


Nombre de messages : 455
Age : 20
Date d'inscription : 26/07/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 19:57

pascalh4 a écrit:

Petit point également: Pour savoir que j'ai une réponse à ce post, y a t-il un moyen plus rapide que de revenir sur la page accueil et ....

non sois tu actualise a la fin sinon tu demende a ceux que on t'avertit par mail mais c'est long

Citation :
De plus lorsque je suis en mode animé je n'arrive plus à revenir en mode action( fenêtre de départ)

tu doit cliquer sur "ecranDebase" et ça te ramenne sur l'ecran de base XD
Revenir en haut Aller en bas
http://guerredesclans.activebb.net
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 20:06

oui mais si je clique sur écran de base, il me raffiche le bouton mais sans retrouver la fenêtre de départ. et si je clique à nouveau sur le bouton il me replace en "mode animé", alors qu'a l'origine il m'afficahit la fenêtre "attribut d'édition".
Et je ne sais toujours pas où rentrer mon code.
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 21:10

On peut peut-être reprendre ta question à zéro, et trouver un moyende e réaliser ton animation SANS programmation.

Par exemple en utilisant l'Ascenseur.
Comment fonctionne l'ascenseur ?
L'ascenseur déplace le curseur temps dans un groupe.

Autrement dit : - quand le visiteur place l'asnecuer en haut -> le groupe se place sur le temps 0
- quand le visiteur descend l'ascenseur -> le groupe passe au temps 1, puis 2... puis 10... puis 30
- dès que le visiteur s'arrète, le curseur-temp s'arrète
- si le visiteur descend jusqu'en bas -> le curseur-temps arrive au temps 100
- ensuite, le visiteur peut remonter et descendre le curseur -> le curseur temps se déplacera encore, et encore, et encore...

Comment accéder à l'Ascenseur ?
1 - Menu : "Objets dynamiques/Objets clefs en main/Bibliothèques de Sprite/Ascenseur"
2 - Voir la vidéo : http://www.e-anim-forum.com/sprites-f24/texte-avec-ascenseur-t5691.htm

IMPORTANT : dans cette viéo je propose un texte qui monte et descend, mais on peut placer n'importe quelle animation entre le temps 0 et le temps 100 - par exemple un objet qui devient progressivement transparent.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: Re: [Résolu] problème de débutant   Ven 27 Nov 2009, 22:04

Merci pour la réponse. je vais essayer de la mettre en pratique.

Par contre (sans vouloir forcément passer par cette méthode) j'aimerai comprendre pourquoi je n'arrive pas à mettre en application "programmer un curseur"

http://www.e-anim-forum.com/programation-f23/programmer-un-curseur-merci-fastoche-t5032.htm

J'essaye certes de répondre à un besoin, mais également de comprendre certains mécanismes. Alors si j'avais une petite piste de méthodologie, ce serait sympa. Les explications de tuto sont certainement évidente pour quelqu'un qui maitrise, mais pas encore pour moi .

Quoiqu'il en soit merci encore et bonne nuit.
Revenir en haut Aller en bas
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: Re: [Résolu] problème de débutant   Sam 28 Nov 2009, 14:51

j'ai fait un petit essai avec l'ascenseur, cela fonctionne à merveille avec un ascenseur,
mais si j'en place deux pour pouvoir faire varier deux images différentes, à ce moment un seul ascenseur fonctionne le deuxième active partiellement le premier et c'est tout (je parle uniquement du déplacement du curseur).

J'imagine qu'il y a un problème de répétition de nom. Que faut il faire pour que les ascenseurs soient dissociés?

Nota : comment faut il procéder pour joindre le swf, qui serait certainement plus explicite? Faut il le placer sur une url spécifique?
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: [Résolu] problème de débutant   Sam 28 Nov 2009, 15:41

pascalh4 a écrit:
j'ai fait un petit essai avec l'ascenseur, cela fonctionne à merveille avec un ascenseur,
mais si j'en place deux pour pouvoir faire varier deux images différentes, à ce moment un seul ascenseur fonctionne le deuxième active partiellement le premier et c'est tout (je parle uniquement du déplacement du curseur).

J'imagine qu'il y a un problème de répétition de nom. Que faut il faire pour que les ascenseurs soient dissociés?
je vais regarder ça et je te réponds ce soir.

pascalh4 a écrit:
Nota : comment faut il procéder pour joindre le swf, qui serait certainement plus explicite? Faut il le placer sur une url spécifique?
Tout d'abord, il faut placer le fichier SWF dans un "site-Internet". As-tu placé tu fichier sur internet ?

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
pascalh4
Intéressé(e)
Intéressé(e)


Nombre de messages : 56
Age : 59
Localisation : Dombasle sur Meurthe 54
Date d'inscription : 27/11/2009

Message Sujet: Re: [Résolu] problème de débutant   Sam 28 Nov 2009, 16:10

Citation :
Tout d'abord, il faut placer le fichier SWF dans un "site-Internet". As-tu placé tu fichier sur internet ?

non, et je n'ai pas de site. y a t-il des services qui permettent ce genre de stockage?
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: [Résolu] problème de débutant   Sam 28 Nov 2009, 16:44

pascalh4 a écrit:
Citation :
Tout d'abord, il faut placer le fichier SWF dans un "site-Internet". As-tu placé tu fichier sur internet ?

non, et je n'ai pas de site. y a t-il des services qui permettent ce genre de stockage?
Oui, archive-host par exemple :
http://www.e-anim-forum.com/tutos-pour-internet-f29/placer-vos-fichiers-sur-internet-archive-host-t5967.htm

Tu m'écris quand tu as placé ton ficheir SWF dans archive-host (où bien si tu rencontres des difficultés)

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: [Résolu] problème de débutant   Aujourd'hui à 19:13

Revenir en haut Aller en bas
 
[Résolu] problème de débutant
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 3Aller à la page : 1, 2, 3  Suivant
 Sujets similaires
-
» [Résolu] Problème de groupe importé
» [Résolu] Problème avec psg tv
» [Résolu] Problème affichage diapo powerpoint sous firefox
» [Résolu] problème freewifi hotspots
» [Résolu] Problème boite de réception Outlook Express

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Comment faire :: Sujets résolus ou sans suite-
Sauter vers: