compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Problème d'image à la création du .swf

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
tarnaur
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 10
Date d'inscription : 23/02/2009

Message Sujet: Problème d'image à la création du .swf   Dim 03 Jan 2010, 02:17

Bonjour,

Cela faisait bien longtemps que je n'étais pas venu ici, j'avais arrêté de faire des animation flash depuis un petit moment.

A l'occasion de l'amélioration d'un site, j'ai eu besoin de faire une animation avec e-anim, et tout se passe bien, je fait bouger des images, bref aucun problème...

Jusqu'au moment ou je créé mon .swf, et quand je décide de tester l'animation, certaines images sont remplacées par des carrés rouges !! A la base, ces images sont des petites etoiles jaunes sur fond transparent ( au format .png ) qui se déplacent sur toutes la longueur de l'animation et qui tournent sur elles-mêmes. Ce qui m'étonne, c'est que je n'ai jamais eu aucun soucis avec des images .png, et que dans le logiciel ( avec shift+play ), je n'ai aucun problème. J'en ai uniquement lors du passage en .swf ( qui ne m'affiche aucune erreur ).

Je voulais donc savoir si vous avez une idée d'où peut venir mon problème. Sad

Merci d'avance. Smile


Dernière édition par tarnaur le Dim 03 Jan 2010, 14:28, édité 1 fois
Revenir en haut Aller en bas
bonhomme
Programmeur


Nombre de messages : 1147
Age : 21
Localisation : Belgique
Date d'inscription : 24/09/2009

Message Sujet: Re: Problème d'image à la création du .swf   Dim 03 Jan 2010, 14:04

je comprend pas le problème oO
Revenir en haut Aller en bas
tarnaur
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 10
Date d'inscription : 23/02/2009

Message Sujet: Re: Problème d'image à la création du .swf   Dim 03 Jan 2010, 14:24

voila mon problème :

dans e-anim ( shift + play ) :
http://www.turboimagehost.com/p/2636794/normal.png.html
mes petites étoiles bougent sur l'image

dans le .swf :
http://www.turboimagehost.com/p/2636779/test2.png.html
des carrés rouges bougent sur l'image !

mes étoiles deviennent des carrés rouges Sad
Revenir en haut Aller en bas
tarnaur
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 10
Date d'inscription : 23/02/2009

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 14:39

bon, si ça peux aider les gens à se pencher sur le sujet, je vous fourni les fichiers

megaupload.com RRIIEPCS

j'espère que vous trouverez la solution Sad
Revenir en haut Aller en bas
Rock Lee
Accro
Accro


Nombre de messages : 4693
Date d'inscription : 03/05/2006

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 15:34

bonjour

les petites images n'ont pas assez de couleurs
Revenir en haut Aller en bas
tarnaur
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 10
Date d'inscription : 23/02/2009

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 15:39

Comment ca ? Shocked

Le fait que mes images sont des petites étoiles jaunes sur fond transparents, ça fait que le logiciel les remplace par des carrés rouges ? O_O

Comment je fais moi alors Sad
Revenir en haut Aller en bas
Rock Lee
Accro
Accro


Nombre de messages : 4693
Date d'inscription : 03/05/2006

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 15:59

lorsque les images n'ont pas assez de couleurs elle sont remplacées par des carrés rouge

montré une image s'il vous plait
Revenir en haut Aller en bas
tarnaur
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 10
Date d'inscription : 23/02/2009

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 16:45

mon image d'étoile c'est ça :



donc le soucis viens du fait qu'il n'y a pas assez de couleurs différentes sur mon image, ou pas assez de pixel de couleur sur l'image ? ( ou juste une image trop petite ? )
Revenir en haut Aller en bas
tarnaur
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 10
Date d'inscription : 23/02/2009

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 16:51

Je viens de changer d'image, j'ai mit une étoile plus grosse :



et maintenant ça marche bien !! merci beaucoup Smile
Revenir en haut Aller en bas
Rock Lee
Accro
Accro


Nombre de messages : 4693
Date d'inscription : 03/05/2006

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 16:52

tu as auto résolu ton problème Smile
Revenir en haut Aller en bas
tarnaur
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 10
Date d'inscription : 23/02/2009

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 17:22

Grâce à tes indications ! merci beaucoup ! cheers
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème d'image à la création du .swf   Lun 04 Jan 2010, 22:27

tarnaur a écrit:
Grâce à tes indications ! merci beaucoup ! cheers
Effectivement, les images doivent avoir au moins 6 couleurs, sinon elle deviennent "rectangle rouge"

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: Problème d'image à la création du .swf   Aujourd'hui à 21:06

Revenir en haut Aller en bas
 
Problème d'image à la création du .swf
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Petit problème avec l'image de fond
» Problème d'image !
» Problème d'image sur la Bbox TV ?
» Problème d'image de fond (background)
» Problème d'image du fond des titres

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: