compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 bug ou mauvaise utilisation ( resolu )

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
newwebdabster
Accro
Accro


Nombre de messages : 341
Date d'inscription : 11/03/2009

Message Sujet: bug ou mauvaise utilisation ( resolu )   Lun 21 Juin 2010, 23:00

salut

comme dans mon message précèdent , je voulais que des groupes agissent les uns sur les autres : la ; presque ok car j'ai du feinter pour arriver a mes fins

mais , un autre soucis est venu me torturer , je voulais que ceux ci puissent se passer devant les uns des autres pour un effet visuel et ici ; l'action de mes groupes a été annule ( semble t'il ) par la fonction "passer devant" que l'on trouve dans attributs pièces car si je décoche cette action passer devant : tout redevient normal

arg , est t 'il possible d'utiliser l'action passer devant et une action du style gotoGroup(animmain.1,3); en même temps sur le même groupe ?


Dernière édition par newwebdabster le Jeu 01 Juil 2010, 13:26, édité 1 fois
Revenir en haut Aller en bas
http://www.dailymotion.com/video/x18fgw_beastie-boys-sabotage_fu
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 03:11

newwebdabster a écrit:
salut

comme dans mon message précèdent , je voulais que des groupes agissent les uns sur les autres : la ; presque ok car j'ai du feinter pour arriver a mes fins

mais , un autre soucis est venu me torturer , je voulais que ceux ci puissent se passer devant les uns des autres pour un effet visuel et ici ; l'action de mes groupes a été annule ( semble t'il ) par la fonction "passer devant" que l'on trouve dans attributs pièces car si je décoche cette action passer devant : tout redevient normal

arg , est t 'il possible d'utiliser l'action passer devant et une action du style gotoGroup(animmain.1,3); en même temps sur le même groupe ?
Le "passer-devant" crées une action qui empêche d'en placer d'autres. mais il existe une solution avec une seule ligne de programme.

Tu ajoutes cette ligne dans le script :
_root.nomdugroup.swapDepths(100);

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
newwebdabster
Accro
Accro


Nombre de messages : 341
Date d'inscription : 11/03/2009

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 20:11

ben , zut ca ne marche pas !!

je dois bien placer ton code dans programmer et non dans action script
et, il y a t'il un ordre a respecter : je dois mettre le code devant les autres instructions ou apres ?

j'ai essaye sur un exemple simple pourtant mais rien n'y fait .....

help , please
Revenir en haut Aller en bas
http://www.dailymotion.com/video/x18fgw_beastie-boys-sabotage_fu
bonhomme
Programmeur


Nombre de messages : 1147
Age : 21
Localisation : Belgique
Date d'inscription : 24/09/2009

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 21:58

ce script doit ce placer dans la zone action script Wink
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 22:13

Ce script fonctionne dans les 2 modes.

Donc, il doit fonctionner dans "programmer". Je l'ai testé.

Quel est le nom de ton groupe qui doit "passer devant" ?

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
newwebdabster
Accro
Accro


Nombre de messages : 341
Date d'inscription : 11/03/2009

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 22:30

voila ce que j'ai mis dans programmer : ( b001 etant mon objet ou groupe )
_root.b001.swapDepths(100);
run_walk(_root.b001,_root.b002,50,null);

sans passer devant : ok
avec passer devant : rien

cela devrait etre ok non ?

j'ai teste aussi ceci :
_root.b001.swapDepths(100);
play();

pensant que j'avais utilise une action trop " complexe " mais pas mieux ...

sans passer devant : ok
avec passer devant : rien





Revenir en haut Aller en bas
http://www.dailymotion.com/video/x18fgw_beastie-boys-sabotage_fu
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6231
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 22:55

je m'étais amusé a faire une petite anim pour illustrer

http://photomaniak.com/upload/out.php/i989944_changercouche.swf
Revenir en haut Aller en bas
http://geranim.free.fr/
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 23:15

J'ai testé avec '_root.play()' comme second action.
Ici, ça fonctionne.

Clic sur le bouton :


Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
newwebdabster
Accro
Accro


Nombre de messages : 341
Date d'inscription : 11/03/2009

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mar 22 Juin 2010, 23:55

donc si je comprend bien le fonction : _root.b001.swapDepths(100); permet a mon groupe b001 de "sauter les niveaux et de passer devant toutes les autres pieces : mais en fait ( je me suis mal explique : merci gerard tu m'a fait comprendre la fonction "_root.b001.swapDepths(100);") , je parle depuis le debut du "passer devant " que l'on trouve dans attribut piece juste en dessous de " non draggable / curseur souris / draggable / etc .... "

je veux utiliser "passer devant " en cochant cette fontion dans les attributs pieces et en meme temps pouvoir utiliser mon groupe pour activer / faire bouger / stopper un autre groupe ou un autre objet

voila

ou alors ; phides , dans l'anime précédente , peux tu activer le " passer devant " de l'objet b001 au passage de la souris et faire que b001 fasse avancer le rectangle au clic souris ?

telle est la question
Very Happy Very Happy Very Happy

je rajoute ceci pour conclure : http://assoc.pagespro-orange.fr/tolerie.bavoysi/demo/test01.html
Revenir en haut Aller en bas
http://www.dailymotion.com/video/x18fgw_beastie-boys-sabotage_fu
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6231
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mer 23 Juin 2010, 13:21

dans l'anim que j'ai fait,faudrait rajouter les codes pour:

descendre où remonter d'une seule couche

et poser sur le fond
Revenir en haut Aller en bas
http://geranim.free.fr/
newwebdabster
Accro
Accro


Nombre de messages : 341
Date d'inscription : 11/03/2009

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mer 23 Juin 2010, 18:46

c'est vu , mais tes objets ne change pas de couche au passage de la souris !
et c'est ce que je veux
Revenir en haut Aller en bas
http://www.dailymotion.com/video/x18fgw_beastie-boys-sabotage_fu
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6231
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mer 23 Juin 2010, 19:36

tu transformes tes objets en boutons animés et tu mets l'action au survol pour changer de couche
j'ai pas testé mais je ne vois pas pourquoi çà ne marcherait pas
Revenir en haut Aller en bas
http://geranim.free.fr/
newwebdabster
Accro
Accro


Nombre de messages : 341
Date d'inscription : 11/03/2009

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mer 23 Juin 2010, 20:17

bon ok , je devoile mon projet : je voulais que les objets se passe devant dans cette anim : http://assoc.pagespro-orange.fr/tolerie.bavoysi/demo/diapo_avec_curseur_test_02.html
mais si je les transforme en bouton anime , l'effet avec la souris disparait : grrrrrrrrrrrr
Revenir en haut Aller en bas
http://www.dailymotion.com/video/x18fgw_beastie-boys-sabotage_fu
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6231
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mer 23 Juin 2010, 20:44

c'est fait avec le curseur élastique?
Revenir en haut Aller en bas
http://geranim.free.fr/
newwebdabster
Accro
Accro


Nombre de messages : 341
Date d'inscription : 11/03/2009

Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Mer 23 Juin 2010, 21:02

oui :D
Revenir en haut Aller en bas
http://www.dailymotion.com/video/x18fgw_beastie-boys-sabotage_fu
Contenu sponsorisé




Message Sujet: Re: bug ou mauvaise utilisation ( resolu )   Aujourd'hui à 09:09

Revenir en haut Aller en bas
 
bug ou mauvaise utilisation ( resolu )
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» barre de navigation et mauvaise utilisation du tutoriel
» [RESOLU] Modification de la taille de la police du manuel d'utilisation DEZL
» Kaspersky utilisation ? ( résolu )
» Roll-over (Resolu)
» [Résolu] Utilisation de REGCLEANER (sauvegarde)

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: