compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 [Resolu] insertion diaporama dans site

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
KYR78
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 3
Date d'inscription : 23/11/2011

Message Sujet: [Resolu] insertion diaporama dans site   Lun 05 Déc 2011, 20:05

Bonjour.
Voila depuis peu je tente de réaliser un petit site en flash à l'aide de E anim selon le tuto
http://infoprographiesimple.free.fr/cours_creer_site_flash/cours_creer_site_flash.php

J'ai placé un simple diaporama dans celui ci et l'animation fonctionne parfaitement après avoir cliqué sur le bouton photos du site.(le diaporama s'ouvre dans corps.phi)
Mon problème est que si j'interromps le diaporama en cliquant sur un autre bouton du menu j'ouvre bien la page du bouton, mais celle ci s'ouvre en grand et non dans la partie corps de mon site. (la frame s'ouvre dans le navigateur et non dans le fichier corps.phi)

J'utilise E anim FX et j'ai essayé de positionner un cadre vide avec la  fonction "this._lockroot=false;" comme expliqué ici http://infoprographiesimple.free.fr/cours_creer_site_flash/i_eanim_fx_lockroot.php
mais je ne comprends pas pourquoi cela ne fonctionne pas avec le diaporama alors que je n'ai pas de problème pour les autres animations.
Merci
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: [Resolu] insertion diaporama dans site   Mar 06 Déc 2011, 01:11

Bonsoir,

Je ne comprends pas bien ce que tu souhaites faire.

Que signifie exactement "corp.phi" ?

Phildes

KYR78 a écrit:
Bonjour.
Voila depuis peu je tente de réaliser un petit site en flash à l'aide de E anim selon le tuto
http://infoprographiesimple.free.fr/cours_creer_site_flash/cours_creer_site_flash.php

J'ai placé un simple diaporama dans celui ci et l'animation fonctionne parfaitement après avoir cliqué sur le bouton photos du site.(le diaporama s'ouvre dans corps.phi)
Mon problème est que si j'interromps le diaporama en cliquant sur un autre bouton du menu j'ouvre bien la page du bouton, mais celle ci s'ouvre en grand et non dans la partie corps de mon site. (la frame s'ouvre dans le navigateur et non dans le fichier corps.phi)

J'utilise E anim FX et j'ai essayé de positionner un cadre vide avec la fonction "this._lockroot=false;" comme expliqué ici http://infoprographiesimple.free.fr/cours_creer_site_flash/i_eanim_fx_lockroot.php
mais je ne comprends pas pourquoi cela ne fonctionne pas avec le diaporama alors que je n'ai pas de problème pour les autres animations.
Merci

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
KYR78
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 3
Date d'inscription : 23/11/2011

Message Sujet: Re: [Resolu] insertion diaporama dans site   Mar 06 Déc 2011, 02:04

Merci pour la rapidité.
En fait corps.html construit à partir de corps.phi est le masque principal du site ou je souhaite importer des pages html, animation etc.. En ce qui concerne les photos j'importe le diaporama dans corps.html et cela fonctionne bien jusqu'au moment ou je clique sur un bouton du menu du site pour importer autre chose dans le masque corps.html.
Si j'applique le tuto en inserant le code this._lockroot=false; a un cadre vide
http://infoprographiesimple.free.fr/cours_creer_site_flash/i_eanim_fx_lockroot.php
le diaporama s'affiche bien mais reste fixe sur la première photo.
Si j'insère aucun code, le diaporama fonctionne correctement et les photos défilent mais lorsque j'appelle une autre page html dans corps.htm cette autre page s'affiche dans tout le navigateur et non à l'emplacement de corps.html.


J'espère que c'est un peu plus clair.
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: [Resolu] insertion diaporama dans site   Mar 06 Déc 2011, 03:14

Bonsoir,

C'est effectivement le fonctionnement normal des changement de page HTML.
Quand vous cliquer sur un lien, le lien prend l'ensemble de la zone du navigateur.

Les boutons Flash fonctionnent comme tous les boutons d'Internet -> il affiche une nouvelle page dans le navigateur.

A bientôt Very Happy

Phildes

KYR78 a écrit:
Merci pour la rapidité.
En fait corps.html construit à partir de corps.phi est le masque principal du site ou je souhaite importer des pages html, animation etc.. En ce qui concerne les photos j'importe le diaporama dans corps.html et cela fonctionne bien jusqu'au moment ou je clique sur un bouton du menu du site pour importer autre chose dans le masque corps.html.
Si j'applique le tuto en inserant le code this._lockroot=false; a un cadre vide
http://infoprographiesimple.free.fr/cours_creer_site_flash/i_eanim_fx_lockroot.php
le diaporama s'affiche bien mais reste fixe sur la première photo.
Si j'insère aucun code, le diaporama fonctionne correctement et les photos défilent mais lorsque j'appelle une autre page html dans corps.htm cette autre page s'affiche dans tout le navigateur et non à l'emplacement de corps.html.


J'espère que c'est un peu plus clair.

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
KYR78
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 3
Date d'inscription : 23/11/2011

Message Sujet: Re: [Resolu] insertion diaporama dans site   Mer 07 Déc 2011, 21:55

Bonsoir.

Je comprends bien mais il est possible de charger une animation à un endroit précis (partie corps) dans mon site et non dans la totalité du navigateur.
J'y arrive avec de simple fihier.swf.
Je charge une première animation dans la partie corps et peut l interrompre en chargeant une seconde animation grâce au menu du site. Cette seconde animation vient se jouer dans la partie corps du site et non dans une nouvelle page du navigateur.
Je bloque avec le sprite de Torak Diaporama qui se charge correctement au début. L'animation se déroule bien, je vois les photos se succéder. Le problème arrive quand je souhaite interrompre l'animation du diaporama en appelant une seconde animation grâce au menu du site. Cette seconde animation au lieu de s'ouvrir dans la partie corps du site, s'ouvre dans une page blanche du navigateur (nouvelle page).
Je sais que mon problème peut être résolu, certainement par quelques lignes de code, mais étant novice j'ai du mal à me faire comprendre,désolé.
Est il possible de vous envoyer mes quelques fichiers pour que vous rendiez compte par vous même.

A Bientot
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18416
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: [Resolu] insertion diaporama dans site   Jeu 08 Déc 2011, 03:34

Bonjour,

Pour ne modifier qu'une partie de la pages HTML, tu dois créer un commande Javascript dans ta page HTML.
Note : un epartie de page se nomme une 'div'

Connais-tu le traitement des divs ? oui - non
Connais-tu le Javascript ? oui - non

Phildes

KYR78 a écrit:
Bonsoir.

Je comprends bien mais il est possible de charger une animation à un endroit précis (partie corps) dans mon site et non dans la totalité du navigateur.
J'y arrive avec de simple fihier.swf.
Je charge une première animation dans la partie corps et peut l interrompre en chargeant une seconde animation grâce au menu du site. Cette seconde animation vient se jouer dans la partie corps du site et non dans une nouvelle page du navigateur.
Je bloque avec le sprite de Torak Diaporama qui se charge correctement au début. L'animation se déroule bien, je vois les photos se succéder. Le problème arrive quand je souhaite interrompre l'animation du diaporama en appelant une seconde animation grâce au menu du site. Cette seconde animation au lieu de s'ouvrir dans la partie corps du site, s'ouvre dans une page blanche du navigateur (nouvelle page).
Je sais que mon problème peut être résolu, certainement par quelques lignes de code, mais étant novice j'ai du mal à me faire comprendre,désolé.
Est il possible de vous envoyer mes quelques fichiers pour que vous rendiez compte par vous même.

A Bientot

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: [Resolu] insertion diaporama dans site   Aujourd'hui à 21:15

Revenir en haut Aller en bas
 
[Resolu] insertion diaporama dans site
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [Resolu] insertion diaporama dans site
» Diaporama dans un sujet ?
» Problème d'insertion HTML dans les post
» Intégration forum dans site existant
» insertion image dans discussion ChatBox

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: