compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 [Resolu] Bug musique

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3, 4, 5, 6  Suivant
AuteurMessage
Xena
Co-administrateur
Co-administrateur


Nombre de messages : 6181
Localisation : Dead zone
Date d'inscription : 21/08/2010

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 12:14

Bonjour kiwi ...
Décidément, FF n'est pas ton copain ....
Pour utiliser le lecteur de Torak :
Déjà, tu télécharges le sprite comme indiqué : http://www.tuto-eanim.fr/tuto-eanim/?q=node/665
Tu le retrouveras dans le lutin, sous la vignette des utilitaires (oublie pas de l'installer)
Ensuite, quand tu l'auras mis sur ton plan de travail, tu vas à > projet > programmation Mtasc.
Le Mtasc va s'ouvrir, tu verras le script.
Là, tu suis les instructions de Torak (post plus haut) et tu cliques "compiler" (en haut)
La modification est prise en compte à ce moment là.
Il te reste à revenir sur ton plan de travail, double-cliquer sur le sprite, et renseigner la fenêtre d'attributs

_________________

Base de documentation  :
Le Site de Tutos Eanim
Mes pages perso
Revenir en haut Aller en bas
http://www.tuto-eanim.fr/site_perso/pages/accueil_perso.php
kiwi
Accro
Accro


Nombre de messages : 184
Localisation : Souvent dans les nuages
Divers : Travail de la terre
Loisirs : Vélo, photo, météo, informatique, blog-nature...
Date d'inscription : 06/12/2007

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 12:51

Eh bien, désolé Xena, mais je ne comprends pas la téchnique.

Edit : ah ben si, ça y est , c'est en place (FF à la rue encore une fois).

Bon, je vais essayer d'en faire quelque-chose maintenant. Merci Xena et Torak.
Revenir en haut Aller en bas
kiwi
Accro
Accro


Nombre de messages : 184
Localisation : Souvent dans les nuages
Divers : Travail de la terre
Loisirs : Vélo, photo, météo, informatique, blog-nature...
Date d'inscription : 06/12/2007

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 13:37

Mesdames, Messieurs, en dépit du bon sens, je suis au regret de vous dire que ça ne fonctionne toujours pas sur mon blog sous FF .
J'ai donc demandé en dernier recours l'ouverture du java-script afin de voir si ça a à voir avec mes problèmes de sons.
Je vous tiens au jus.
Revenir en haut Aller en bas
TORAK
Accro
Accro


Nombre de messages : 1452
Age : 27
Localisation : Ain
Loisirs : prog, soft, hardware, sciences physiques & cosmologie
Date d'inscription : 23/12/2008

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 15:19

Tu as installé le sprite en question ? intégré dans une anim ?

Si oui, peut on voir le résultat ? Je serais curieux de voir ça Very Happy

ps: pour ton problème de blocage c'est encore plus curieux puisqu'il n'y a vraiment pas grand chose de lourd à l'affichage! (il faudrait que tu bloque toute les animations flash pour voir si ça vient de ça -> Flashblock )

@Xena: voui pour limiter les répétitions:
remplacer:
Citation :
sonMP3.onSoundComplete = function (){
if(!lock){
repet++;
sonMP3.start(0);
}
};

Par:
Citation :

var repetition:Number = 2;
sonMP3.onSoundComplete = function (){
if(!lock && repet < repetition){
repet++;
sonMP3.start(0);
}
};
var repetition:Number = 2; que tu peux placer au début du script Wink
désolé d'avoir zappé ça, mais au départ c'est TON sprite
Laughing Razz


Dernière édition par TORAK le Mer 03 Oct 2012, 16:33, édité 2 fois
Revenir en haut Aller en bas
http://torak01.fr/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6236
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 16:06

c'est impecc comme çà,on peut choisir le nombre de fois que çà doit boucler
Revenir en haut Aller en bas
http://geranim.free.fr/
Xena
Co-administrateur
Co-administrateur


Nombre de messages : 6181
Localisation : Dead zone
Date d'inscription : 21/08/2010

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 16:10

Laughing Merci Torak !

_________________

Base de documentation  :
Le Site de Tutos Eanim
Mes pages perso
Revenir en haut Aller en bas
http://www.tuto-eanim.fr/site_perso/pages/accueil_perso.php
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6236
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 16:13

Very Happy

Revenir en haut Aller en bas
http://geranim.free.fr/
Xena
Co-administrateur
Co-administrateur


Nombre de messages : 6181
Localisation : Dead zone
Date d'inscription : 21/08/2010

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 16:39

La claaaaaasssssse ! Very Happy

_________________

Base de documentation  :
Le Site de Tutos Eanim
Mes pages perso
Revenir en haut Aller en bas
http://www.tuto-eanim.fr/site_perso/pages/accueil_perso.php
kiwi
Accro
Accro


Nombre de messages : 184
Localisation : Souvent dans les nuages
Divers : Travail de la terre
Loisirs : Vélo, photo, météo, informatique, blog-nature...
Date d'inscription : 06/12/2007

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 18:56

Bonsoir tous,
ah tu veux voir Torak ? Alors, c'est là blog (J'ai fait au plus simple).
Tu verras aussi le diapo du dessus, il ne fonctionne pas non plus.
J'ai remarque que, quand j'affiche l'anim sur mon pc hors connexion même avec FF, je n'ai pas la barre de défilement en dessous, alors qu'il y est une fois sur le blog (?).

Joli Gérard, et en plus, je l'entends.
Revenir en haut Aller en bas
sateene
Accro
Accro


Nombre de messages : 2899
Age : 56
Localisation : Gard
Date d'inscription : 03/01/2010

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 19:03

superbe gerard et on entend très bien

Magnifique ton site Kiwi et ça marche cheers
Revenir en haut Aller en bas
kiwi
Accro
Accro


Nombre de messages : 184
Localisation : Souvent dans les nuages
Divers : Travail de la terre
Loisirs : Vélo, photo, météo, informatique, blog-nature...
Date d'inscription : 06/12/2007

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 19:14

Bonsoir et merci Sateene.
Ca marche chez toi ? avec quoi ?
Si c'est avec Chrome ou IE , oui, mais avec FF ?
Revenir en haut Aller en bas
sateene
Accro
Accro


Nombre de messages : 2899
Age : 56
Localisation : Gard
Date d'inscription : 03/01/2010

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 19:23

je viens de regarder , j'entends très bien sous chrome, mais rien sous FF et safari
Revenir en haut Aller en bas
Xena
Co-administrateur
Co-administrateur


Nombre de messages : 6181
Localisation : Dead zone
Date d'inscription : 21/08/2010

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 19:35

Grrrr ! pareil que Sateene
IE et Chrome = oui
FF et Safari = non

_________________

Base de documentation  :
Le Site de Tutos Eanim
Mes pages perso
Revenir en haut Aller en bas
http://www.tuto-eanim.fr/site_perso/pages/accueil_perso.php
kiwi
Accro
Accro


Nombre de messages : 184
Localisation : Souvent dans les nuages
Divers : Travail de la terre
Loisirs : Vélo, photo, météo, informatique, blog-nature...
Date d'inscription : 06/12/2007

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 19:39

Et voilà !
et ça ne marche pas non plus sur archive-host avec FF.
Revenir en haut Aller en bas
TORAK
Accro
Accro


Nombre de messages : 1452
Age : 27
Localisation : Ain
Loisirs : prog, soft, hardware, sciences physiques & cosmologie
Date d'inscription : 23/12/2008

Message Sujet: Re: [Resolu] Bug musique   Mer 03 Oct 2012, 19:44

Ah oui, il y a un lézard kiwi !
Tu as bien fait Projet > Programmation Mtasc > Compiler (dans PAUSE.as) ?
On dirait que seul la moitier du script AS est prit en compte !?


J'ai fait quelque test avec ton mp3.... J'ai rarement vu ça mais il déconne, ou est corrompu. C'est sure que ça vient de ça !
En fait je ne reçoit pas toute les données nécessaire au bon fonctionnement du script (même si pour moi, la zik démarre bien, mais en local seulement)
c'est bien visible -> http://torak01.fr/media/test/PAUSE.swf
Au lieu de grand nombres je reçoit 0 et undefined ! lool

Bref, réencode correctement ton mp3 ou essaye avec un autre (par exemple : http://torak01.fr/media/music/ogame/Audiomachine%20-%20Dark%20Evolution.mp3 )
Apparemment Firefox bloque les fichier corrompus, ou ne sait pas quoi en faire ^^

Une autre chose que je comprend pas, pourquoi ta barre de son ne fonctionne pas ? elle devrait être cliquable comme dans mon exemple...


Dernière édition par TORAK le Mer 03 Oct 2012, 19:49, édité 2 fois
Revenir en haut Aller en bas
http://torak01.fr/
Contenu sponsorisé




Message Sujet: Re: [Resolu] Bug musique   Aujourd'hui à 23:05

Revenir en haut Aller en bas
 
[Resolu] Bug musique
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 4 sur 6Aller à la page : Précédent  1, 2, 3, 4, 5, 6  Suivant
 Sujets similaires
-
» (RESOLU) comment transferer musique ipad vers pc?
» besion d'aide language html lecteur de musique !! (Résolu)
» Quel est votre style de musique???
» Plus capable de sa "foutu" musique.. désolé le terme...
» Roll-over (Resolu)

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Problème, bug :: Sujets résolus-
Sauter vers: