compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : 1, 2  Suivant
AuteurMessage
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 18:37

Boujour,

Tout est dans le titre ou presque ....!
J'utilise un bouton qui au temps "0" contient:
Code:
soundPause(1);

Pour suspendre le fond sonore, jusque là c'est "normal"
Ensuite un deuxième bouton au temps "10" qui contient:
Code:
soundRestart(1);
---
Cela fonctionne très bien "Sauf que" la plus par du temps le "soundRestart(1);" reprends le fond sonore en début de la mélodie...
Y a-t-il une possibilité pour reprendre le son au "Point" ou il à été "suspendu", je suppose que "oui" avec les fonctions du genre:
"soundGetPause();" ou "soundGetPosition(1);" ou "soundSetPosition(,);" ou autres ...
---
Comment les enchainées....? suis un peu "Paumé"....! Rolling Eyes
J'ai donc une fois de plus Besoin de vos lumières.... Laughing
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 20:09

Bonjour

il faut bien utilisé soundPause et soundRestart

quel est l’intérêt de mettre les boutons à des temps différents?
Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 21:28

gerard35 a écrit:
Bonjour

il faut bien utilisé soundPause et soundRestart

quel est l’intérêt de mettre les boutons à des temps différents?

en fait à l'écran, au temps 0 j'ai le bouton "Pause" avec un "stop", si je clique, le son se met en pause, et passe au temps 10, ou j'ai le bouton "play" avec un stop et "soundRestart" et un goto(0);
Ces deux boutons sont superposés, l'un apparait après l'autre en bascule

Bon donc impossible de reprendre le fond sonore ou à été posé le "soundPause" ...?





Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
Xena
Co-administrateur
Co-administrateur


Nombre de messages : 6181
Localisation : Dead zone
Date d'inscription : 21/08/2010

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 21:51

Bonsoir
As-tu vu qu'il existe un sprite qui répond à ce que tu souhaites ?
http://www.tuto-eanim.fr/Le_site_de_tutos/contenu/niveau_3_pages/sprites_outils/mp3_play_pause_stop.php

_________________

Base de documentation  :
Le Site de Tutos Eanim
Mes pages perso
Revenir en haut Aller en bas
http://www.tuto-eanim.fr/site_perso/pages/accueil_perso.php
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 22:04

Xena a écrit:
Bonsoir
As-tu vu qu'il existe un sprite qui répond à ce que tu souhaites ?
http://www.tuto-eanim.fr/Le_site_de_tutos/contenu/niveau_3_pages/sprites_outils/mp3_play_pause_stop.php

Merci "Xena", j'ai effectivement vu et essayé ce SPrite, malheureusement, j'ai eu beau modifier "démarrage Auto" en "true", rien ni fait... le son ne démarre pas à l'ouvertue , faut cliquer sur la barre de défilement pour le lancer....?????? mystère....?????

J'ai essayé de voir "AS" derrière mais comme c'est de la programmation "Mtasc" ...? Shocked
là suis incompétent Crying or Very sad


Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
Xena
Co-administrateur
Co-administrateur


Nombre de messages : 6181
Localisation : Dead zone
Date d'inscription : 21/08/2010

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 22:11

Désolée ...
Attendons l'avis du créateur du sprite

_________________

Base de documentation  :
Le Site de Tutos Eanim
Mes pages perso
Revenir en haut Aller en bas
http://www.tuto-eanim.fr/site_perso/pages/accueil_perso.php
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 22:17

Xena a écrit:
Désolée ...
Attendons l'avis du créateur du sprite

Ne soit pas désolée "Xena", je comprends le "blème", néanmoins je pense qu'il est possible en même temps que l'on passe un "sounPause()" de connaître la position d'arrêt pour relancer le "soundrestant()" à cette position..
Ce n'est qu'un problème de variable à lui passer....enfin je suppose....!



Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 22:53

c'est curieux

j'ai utilisé ce sprite pour faire cette animation et le son démarre bien tout seul,c'est d'ailleurs pour çà que je l'ai mis sous spoiler

http://www.e-anim-forum.com/t8833p705-galerie-gerard35-n2#137263
Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mar 05 Mar 2013, 23:44

gerard35 a écrit:
c'est curieux
j'ai utilisé ce sprite pour faire cette animation et le son démarre bien tout seul,c'est d'ailleurs pour çà que je l'ai mis sous spoiler
http://www.e-anim-forum.com/t8833p705-galerie-gerard35-n2#137263

Désolé "Gérard" mais chez moi j'ai un "problème" avec ce "Sprite"
Voilà le scan du Groupe, le démarrage auto est bien sur "true"
Spoiler:
 

et voici les liens
1) < Lien du "Html" >
2)< Lien du Swf >

Si tu ne clique pas sur la barre de défilement du bas le son ne démarre pas...?
Because....?



Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
radwolwerine
Accro
Accro


Nombre de messages : 274
Date d'inscription : 08/06/2009

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mer 06 Mar 2013, 07:01

Salut ,je ne vais pas te répondre ,mais juste te dire merci pour ce moment passé sur cette musique cheers
Revenir en haut Aller en bas
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mer 06 Mar 2013, 09:15

Bonjour

tu n'as pas la dernière version du sprite

dans les attributs,tu devrais avoir ceci



edit:repétition,c'est le nombre de fois que la musique est jouée avant de stopper

action:on peut commander un groupe à la fin du Mp3
Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mer 06 Mar 2013, 10:58

Merci Gérard je comprends mieux maintenant...

Je vient de recharger le nouveau "Sprite" donc je vais voir.... Wink

Merci
Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mer 06 Mar 2013, 12:06

Donc après essai du "Sprite" rechargé....Le démarrage "Auto" fonctionne bien Laughing

Par contre après un SoundPause(1); et soundRestart(1); le son redémarre au début Crying or Very sad
donc mon problème pas résolu... Evil or Very Mad
La reprise du son là ou l'on à placé le SoundPause(1); Sad
Y a-t-il une solution ...?



Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
gerard35
Modérateur global
Modérateur global


Nombre de messages : 6239
Localisation : Ille et Vilaine
Date d'inscription : 21/12/2006

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mer 06 Mar 2013, 13:03

il repart au début uniquement si tu clic sur stop puis play

si tu clic sur pause puis play,il repart bien là ou il a été arrêté


essaies dans une nouvelle animation de mettre le lecteur au temps 0 sans rien d'autre et fait le test pause/restart
Revenir en haut Aller en bas
http://geranim.free.fr/
lmc38510
Accro
Accro


Nombre de messages : 402
Age : 69
Localisation : Nord Isère
Date d'inscription : 01/05/2011

Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Mer 06 Mar 2013, 13:05


Merci Gérard, je fait essais.... Wink


Revenir en haut Aller en bas
http://arcanes.lacaverneauxgrimoires-forum.com/
Contenu sponsorisé




Message Sujet: Re: [Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)   Aujourd'hui à 05:55

Revenir en haut Aller en bas
 
[Resolu] à Propos de "soundPause(1);" et "soundRestart(1);)
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 2Aller à la page : 1, 2  Suivant
 Sujets similaires
-
» [ résolu ]à propos de TFC
» Roll-over (Resolu)
» icone(RESOLU par Migau)
» À propos de gifs animés
» À propos des IP

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Comment faire :: Sujets résolus ou sans suite-
Sauter vers: