compteur
 
AccueilPortailFAQS'enregistrerConnexion

Partagez | 
 

 Problème sous linux

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
FLOZz
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 5
Date d'inscription : 16/11/2006

Message Sujet: Problème sous linux   Jeu 16 Nov 2006, 20:28

Bonjour,
Premièrement je tien a vous féliciter pour votre logiciel, qui est toujours aussi génial ^^ (sous windows en tout cas).
Deusièmement, je trouve que c'est une bonne idée de l'avoire rendu compatible avec linux MAIS ça marche pas chez moi ^^' :

Code:
******@*************:~/apps/e-anim$  ./linux_run.sh


|------------------------------------------------------------------|
|              Installation de E-Anim 5.06  licence GNU GPL        |
|------------------------------------------------------------------|


**********************************
*  Java 1.5 est-il installe ?  *
**********************************
tapez O=oui  N=non  P=je_ne_sais_pas  Q=quitter
o

*************************************************
Lien vers Java n'est pas correct
*************************************************
Indiquez le chemin vers Java 5

      (laisser vide si vous l'ignorez / tapez <entree>)
/usr/lib/j2se/1.4/jre/bin/java


|------------------------------------------------------------------|
|    Java 5 reconnu, lancement de E-Anim 5.06  licence GNU GPL    |
|------------------------------------------------------------------|
Exception in thread "main" java.lang.UnsupportedClassVersionError: eanim (Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
******@*************:~/apps/e-anim$

Avez - vous une solution à mon problème ? (j'ai Ubuntu 6.10 - version Edgy Eft)

Merci d'avance et bonne continuation
FLo
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème sous linux   Jeu 16 Nov 2006, 21:23

FLOZz a écrit:
Bonjour,
Premièrement je tien a vous féliciter pour votre logiciel, qui est toujours aussi génial ^^ (sous windows en tout cas).
Merci, ça nous encourage baucoup à continuer. Very Happy

Citation :
Deusièmement, je trouve que c'est une bonne idée de l'avoire rendu compatible avec linux MAIS ça marche pas chez moi ^^' :
...
java.lang.UnsupportedClassVersionError: eanim (Unsupported major.minor version 49.0)
Ce message dit que tu execute une version 4 de Java. => E-Anim réclame une version 5

Est-ce que tu as java vesrion 5 installé sur ton Linux ?

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
FLOZz
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 5
Date d'inscription : 16/11/2006

Message Sujet: Re: Problème sous linux   Jeu 16 Nov 2006, 21:30

D'apres mon gestionaire de packet (Synaptic) java 5 cerai bien installé :
Sun Java(TM) Runtime Environment (JRE) 5.0

d'apres ce meme gestionnaire j'aurai ausi ça d'installé :
Blackdown Java(TM) 2 Runtime Environment, Standard Edition

Le premier semble correspondre à ce que e-anim demande non ?

(merci d'avoir répondu si vte ^^) Very Happy
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème sous linux   Jeu 16 Nov 2006, 21:41

FLOZz a écrit:
D'apres mon gestionaire de packet (Synaptic) java 5 cerai bien installé :
Sun Java(TM) Runtime Environment (JRE) 5.0
Sais-tu dans quel dossier, il se trouve sur ta machine ?


Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
FLOZz
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 5
Date d'inscription : 16/11/2006

Message Sujet: Re: Problème sous linux   Jeu 16 Nov 2006, 21:43

je sait pas exactement ^^'
je suis en train de faire des recherches sur le sujet sur le site de ma distribution ^^
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème sous linux   Jeu 16 Nov 2006, 22:10

FLOZz a écrit:
je sait pas exactement ^^'
je suis en train de faire des recherches sur le sujet sur le site de ma distribution ^^
Ok, j'attedns.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
FLOZz
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 5
Date d'inscription : 16/11/2006

Message Sujet: Re: Problème sous linux   Jeu 16 Nov 2006, 22:39

j'ai trouvé :
/usr/lib/j2se/1.4/jre/bin/java
/home/fabien/.java/deployment
c'est tout...
je pense que je vai essayer de réinstaller java... je vous tien au courant ^^
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème sous linux   Jeu 16 Nov 2006, 23:21

FLOZz a écrit:
j'ai trouvé :
/usr/lib/j2se/1.4/jre/bin/java
/home/fabien/.java/deployment
c'est tout...
je pense que je vai essayer de réinstaller java... je vous tien au courant ^^
OK, je suis toujours là Razz

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
FLOZz
Nouveau (nouvelle)
Nouveau (nouvelle)


Nombre de messages : 5
Date d'inscription : 16/11/2006

Message Sujet: Re: Problème sous linux   Dim 03 Déc 2006, 19:55

J'ai été long (très long) car j'avai des tas de contôles ^^'....
bon ça marche enfin ^^, en fait mon probleme c'était que l'installation de la version 5 du jre échouai, car il arrivai pas à remplacer certain fichier (car il appartenaient a l'utilisateur root (administrateur)) donc voila... je me suis logué en tant que root pour l'installer et c'est bon)

en tout cas merci pour votre soutien, et bonne continuation !!
Revenir en haut Aller en bas
Admin
Administrateur
Administrateur


Nombre de messages : 18417
Localisation : Toulouse
Date d'inscription : 11/12/2005

Message Sujet: Re: Problème sous linux   Dim 03 Déc 2006, 21:34

FLOZz a écrit:
J'ai été long (très long) car j'avai des tas de contôles ^^'....
bon ça marche enfin ^^, en fait mon probleme c'était que l'installation de la version 5 du jre échouai, car il arrivai pas à remplacer certain fichier (car il appartenaient a l'utilisateur root (administrateur)) donc voila... je me suis logué en tant que root pour l'installer et c'est bon)

en tout cas merci pour votre soutien, et bonne continuation !!
Parfait, merci du renseignement et bravo pour ta persévérence.

Phildes

_________________
.
Revenir en haut Aller en bas
http://www.e-anim.com
Contenu sponsorisé




Message Sujet: Re: Problème sous linux   Aujourd'hui à 13:39

Revenir en haut Aller en bas
 
Problème sous linux
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» GM sous linux
» "TV sur Ordinateur" sous Linux
» [Résolu]Problème sous Chrome (Windows) et Chromium (Linux)
» Bug sous linux:
» Game maker sous Linux

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
E-anim :: Utiliser E-anim :: Comment faire :: Sujets résolus ou sans suite-
Sauter vers: